ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

upgrade to 5 not compatiable with Roboform

  • 3 ردود
  • 52 have this problem
  • 5 views
  • آخر ردّ كتبه eckhart

more options

Upgraded to Version 5 this morning on to find out that it is not compatible with Roboform How do I uninstll it and get back to the version that ]worked with Roboform?

All Replies (3)

more options

I have installed the latest Roboform version 7.3.2 on my Windows XP Pro machine. Roboform is running fine now. Note: same applies on my Windows 7 Pro machine.

more options

roelb, how did you do it? I can't seem to. They want me to fork up for another license.

more options

I have been a Roboform Pro user for years, and this disturbed me greatly since I have paid for multiple "lifetime" licenses of Roboform Pro which no longer work with Firefox. My advice: Forget about Roboform and get the free program Last Pass. After I got over the slight learning curve, I find that I like it better than Roboform in most respects. It not only fills forms and saves passwords, it can update your password information on your other computers automatically, which was a constant problem for me with Roboform. The company which owns Roboform should be sued for deceptive trade practices for their marketing of lifetime licenses, but I am happy to say that I can kiss them goodbye forever with a free product which works just as well, and in some cases, better than Roboform.