X
Tap here to go to the mobile version of the site.

منتدى الدعم

Firefox 4 on mac 'snow leopard' (10.6.7) won't open new windows - only tabs

Posted

I upgraded a couple days ago, and just noticed that I cannot open a 'new' window, only tabs in the original window that opens when I initially click the FF icon. I've tried both command-N and clicking file/new window from the menu. If I right-click a tab and select 'move to new window' the tab just goes away - no new window appears. New tabs open without an issue. I've rebooted, but it doesn't help.

I'm running macbook pro 13", 8g ram/1t drive - shouldn't be resource starved. Doesn't appear to matter what else (if anything) is running. The only plug-in I've installed is Adblock.

My previous installation (3.something - was current) 'lost' all my plugins somehow - they showed in the list, but wouldn't run; I removed them all but it wouldn't let me re-install any (I forget the error). That seemed to all get fixed when I upgraded to 4; adblock installed and runs like normal. Not sure if there is any relation, but thought I'd mention it.

Thoughts?

I upgraded a couple days ago, and just noticed that I cannot open a 'new' window, only tabs in the original window that opens when I initially click the FF icon. I've tried both command-N and clicking file/new window from the menu. If I right-click a tab and select 'move to new window' the tab just goes away - no new window appears. New tabs open without an issue. I've rebooted, but it doesn't help. I'm running macbook pro 13", 8g ram/1t drive - shouldn't be resource starved. Doesn't appear to matter what else (if anything) is running. The only plug-in I've installed is Adblock. My previous installation (3.something - was current) 'lost' all my plugins somehow - they showed in the list, but wouldn't run; I removed them all but it wouldn't let me re-install any (I forget the error). That seemed to all get fixed when I upgraded to 4; adblock installed and runs like normal. Not sure if there is any relation, but thought I'd mention it. Thoughts?

Additional System Details

This happened

Every time Firefox opened

This started when...

after upgrade to firefox v4

Installed Plug-ins

  • Picasa plugin.
  • iPhoto6
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave for Director 11.5.9r615
  • Shockwave Flash 10.1 r102
  • Version 1.9.2.1599
  • Google Talk Plugin Video Accelerator version:0.1.43.4
  • Java Plug-In 2 for NPAPI Browsers

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0

More Information

Application Basics
Name
Firefox
Version
4.0
User Agent
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0
Profile Directory
Show in Finder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Adobe Acrobat - Create PDF
1.0
false
web2pdfextension@web2pdf.adobedotcom
FoxTab
1.4.1
true
{ef4e370e-d9f0-4e00-b93e-a4f274cfdd5a}
Adblock Plus
1.3.3
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.history_expire_days.mirror
180
browser.places.importBookmarksHTML
false
browser.places.smartBookmarksVersion
2
browser.startup.homepage_override.buildID
20110318052756
browser.startup.homepage_override.mstone
rv:2.0
extensions.lastAppVersion
4.0
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1301033754
places.history.expiration.transient_current_max_pages
249644
places.last_vacuum
1299861923
print.macosx.pagesetup-2
PD94bWwgdmVyc2lvbj0iMS4wIiBlbmNvZGluZz0iVVRGLTgiPz4KPCFET0NUWVBFIHBsaXN0IFBVQkxJQyAiLS8vQXBwbGUvL0RURCBQTElTVCAxLjAvL0VO…
print.print_bgcolor
false
print.print_bgimages
false
print.print_command
print.print_downloadfonts
false
print.print_evenpages
true
print.print_in_color
true
print.print_margin_bottom
0.5
print.print_margin_left
0.5
print.print_margin_right
0.5
print.print_margin_top
0.5
print.print_oddpages
true
print.print_orientation
0
print.print_pagedelay
500
print.print_paper_data
0
print.print_paper_height
11.00
print.print_paper_size_type
1
print.print_paper_size_unit
0
print.print_paper_width
8.50
print.print_printer
print.print_reversed
false
print.print_scaling
1.00
print.print_shrink_to_fit
true
print.print_to_file
false
print.print_unwriteable_margin_bottom
56
print.print_unwriteable_margin_left
25
print.print_unwriteable_margin_right
25
print.print_unwriteable_margin_top
25
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false
Graphics
Adapter Description
0x22600,0x20400
Vendor ID
0000
Device ID
0000
Adapter RAM
Adapter Drivers
Driver Version
Driver Date
Direct2D Enabled
false
DirectWrite Enabled
false
WebGL Renderer
NVIDIA Corporation -- NVIDIA GeForce 9400M OpenGL Engine -- 2.1 NVIDIA-1.6.26
GPU Accelerated Windows
6/6 OpenGL

xjbx 0 solutions 1 answers

the top alignment fixes the issue, but then the hot corners dont work anymore. at least on mine it doesnt. just upgraded to FF5 and it still has the same issue. VERY frustrating.

the top alignment fixes the issue, but then the hot corners dont work anymore. at least on mine it doesnt. just upgraded to FF5 and it still has the same issue. VERY frustrating.
iDev 0 solutions 1 answers

I can't rearrange my monitors because I need them arranged left/right for software development, but I found that launching into safe mode also avoids the problem.

Hold down the option key when running Firefox, or choose "Restart with add-ons disabled" from the Help menu.

It does disable all your plugins and you have to set things like your bookmarks bar to be visible again, but I can live with that.

I can't rearrange my monitors because I need them arranged left/right for software development, but I found that launching into safe mode also avoids the problem. Hold down the option key when running Firefox, or choose "Restart with add-ons disabled" from the Help menu. It does disable all your plugins and you have to set things like your bookmarks bar to be visible again, but I can live with that.
arakin 0 solutions 3 answers

Hi everyone, I have Snow Leopard 10.6.8. I have been very very frustrated by this problem. [I could not create new windows, and anything that opens new windows, such as trying to see what Add-ons you have etc would not work]. I read about changing screen alignment to the top... I have one screen so the option does not exist. The above messages would not fix this problem. I searched hard and did find a solution in the end. I read stuff about removing Add-ons until the problem is fixed, but its simply not the case.

First of all open Firefox. next go to options: Help --- 'Restart with Add-ons disabled'. Tick the box for add-ons, restart firefox. Next go to Tools --- Add-ons. Next (In the Add-ons Manager' click on 'Plugins' on the left hand side pane. Look for the small blue writing that says 'Check to see if your plugins are up to date'.

Now notice it should say 'Missing Flash'. "For your safety, Firefox has disabled your outdated version of Flash. Please upgrade to the latest version". I followed this, reinstalled Flash and it now works as it always did, no problems. For people where the above fix didn't work, try this one out. Hope it helps people!

o)
Hi everyone, I have Snow Leopard 10.6.8. I have been very very frustrated by this problem. [I could not create new windows, and anything that opens new windows, such as trying to see what Add-ons you have etc would not work]. I read about changing screen alignment to the top... I have one screen so the option does not exist. The above messages would not fix this problem. I searched hard and did find a solution in the end. I read stuff about removing Add-ons until the problem is fixed, but its simply not the case. First of all open Firefox. next go to options: Help --- 'Restart with Add-ons disabled'. Tick the box for add-ons, restart firefox. Next go to Tools --- Add-ons. Next (In the Add-ons Manager' click on 'Plugins' on the left hand side pane. Look for the small blue writing that says 'Check to see if your plugins are up to date'. Now notice it should say 'Missing Flash'. "For your safety, Firefox has disabled your outdated version of Flash. Please upgrade to the latest version". I followed this, reinstalled Flash and it now works as it always did, no problems. For people where the above fix didn't work, try this one out. Hope it helps people! :o)
arakin 0 solutions 3 answers

Hi everyone, I have Snow Leopard 10.6.8. I have been very very frustrated by this problem. [I could not create new windows, and anything that opens new windows, such as trying to see what Add-ons you have etc would not work]. I read about changing screen alignment to the top... I have one screen so the option does not exist. The above messages would not fix this problem. I searched hard and did find a solution in the end. I read stuff about removing Add-ons until the problem is fixed, but its simply not the case.

First of all open Firefox. next go to options: Help --- 'Restart with Add-ons disabled'. Tick the box for add-ons, restart firefox. Next go to Tools --- Add-ons. Next (In the Add-ons Manager' click on 'Plugins' on the left hand side pane. Look for the small blue writing that says 'Check to see if your plugins are up to date'.

Now notice it should say 'Missing Flash'. "For your safety, Firefox has disabled your outdated version of Flash. Please upgrade to the latest version". I followed this, reinstalled Flash and it now works as it always did, no problems. For people where the above fix didn't work, try this one out. Hope it helps people!

o)
Hi everyone, I have Snow Leopard 10.6.8. I have been very very frustrated by this problem. [I could not create new windows, and anything that opens new windows, such as trying to see what Add-ons you have etc would not work]. I read about changing screen alignment to the top... I have one screen so the option does not exist. The above messages would not fix this problem. I searched hard and did find a solution in the end. I read stuff about removing Add-ons until the problem is fixed, but its simply not the case. First of all open Firefox. next go to options: Help --- 'Restart with Add-ons disabled'. Tick the box for add-ons, restart firefox. Next go to Tools --- Add-ons. Next (In the Add-ons Manager' click on 'Plugins' on the left hand side pane. Look for the small blue writing that says 'Check to see if your plugins are up to date'. Now notice it should say 'Missing Flash'. "For your safety, Firefox has disabled your outdated version of Flash. Please upgrade to the latest version". I followed this, reinstalled Flash and it now works as it always did, no problems. For people where the above fix didn't work, try this one out. Hope it helps people! :o)
ultranaut 0 solutions 2 answers

FWIW, this is a known issue and there's a ticket for it. Will supposedly be fixed in FF9.

FWIW, this is a known issue and there's a [https://bugzilla.mozilla.org/show_bug.cgi?id=644733 ticket] for it. Will supposedly be fixed in FF9.