ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

making status bar "done" go away in Firefox 4

  • 9 ردود
  • 24 have this problem
  • 86 views
  • آخر ردّ كتبه cor-el

more options

The new status bar has a "Done" message that sometimes will not go away. This is particularly problematic on Netflix, where "Done" persists, and is irritatingly obvious on the black background. Mousing over it simply makes it switch to the other side of the screen. I can't find any settings related to this - any ideas? I know there's an add-on to go back to the old status bar, which I might resort to, but surely is this solvable in Firefox 4.

I also can't figure out why the "Done" label is sometimes there and sometimes not, and sometimes appears when I haven't loaded a new page.

All Replies (9)

more options

The easiest way is to use the Status-4-Evar add-on. With it you can choose to not display any of the status messages, or display them in the add-ons bar or location bar instead. To just hide the Done message uncheck the setting to "Show default status"

https://addons.mozilla.org/firefox/addon/status-4-evar

more options

Thanks, this is a solution, albeit not perfect. I was actually fine with getting rid of the gray status bar, as long as I could also get rid of "Done", but if this isn't possible, well, I'm used to the gray bar from Firefox 3, so that's okay.

more options

To get rid of "Done", in the status-4-evar settings de-select "Show default status"

more options

Yes, you already said that.

To clarify, it's not distracting when it's separated and in the gray bar. I have turned it off there, but no solution involving the gray status bar and status-4-evar is what I was looking for. I wanted to turn off "Done" in the base Firefox 4 (where it is distracting, because it's not separated from the rest of the screen, and is highlighted in white).

Modified by dsyphers

more options

I've found that the problem is the Multi Links addon!! https://addons.mozilla.org/en-US/firefox/addon/multi-links/ Disable it and the problem stops :)

I've already reported it to it's developer.

Modified by zakk

more options

I don't have the Multi Links add-on installed.

more options

It's definitively one of your installed addons that's causing this. Do what I did in order to find out which one is: uninstall all addons + reinstall one-by-one. There's no other way.

Modified by zakk

more options

Unfortunately, that's certainly not the case for me. The only add-on I had was Flashblock, and removing that didn't affect the problem.

more options

Maybe code in userChrome.css works.

Add code to userChrome.css below the @namespace line.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#statusbar-display[label="Done"] {display:none !important;}