ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 4 and Google toolbar do not play nice together. Clicking on dropdown box does nothing.

  • 42 ردًا
  • 2705 have this problem
  • 4 views
  • آخر ردّ كتبه calandro

more options

Type something into the search box, you start to get suggestions in the drop down. You click on the drop down suggestion and nothing happens. You must type the entire search into the search box for it to stick. I reverted to 3.*** until this is corrected.

All Replies (20)

more options

Same problem with the Yahoo search box. I have to use the arrow keys and enter key. It's a hassle and a step backwards. At least Google has acknowledged this as a "Known Problem".

When is Mozilla going to at least issue a statement?

Modified by Billfisher

more options

As a workaround, try using your keyboard to navigate the drop-down list to select your web history or search suggestions.

more options

The workaround using the keyboard up n down arrows does work (if NoScript is not installed), but it's very awkward. It slows the search activity tremendously.

I've also found that the NoScript add-on completely disables that search box from storing anything. drop down menu in search box remains perpetually blank. And in that case , this workaround using the keyboard arrows doesn't even help at all.

Both these issues began with upgrade to Firefox 4.0

Hopefuly, either Firefox developers or Google toolbar developers can fix these soon.

more options

This has been going on long enough for me to realise that Google are quite happy with this situation and no one is doing a damned thing about it, because they think we will move over to Chrome due to the inconvenience. Well sorry, Google, I will not use your browser... and I'm now going to switch to another search company owing to your shady tactics. I'm not saying you created the issue, but you're definitely looking at it as a positive. After all, what are we talking here? A few simple lines of code at best? It was first reported WEEKS ago, and more people are reporting it by the day - if you were creating an update, we would have had it in days. So for the sake of a few lines of code, this is one user you have lost. Me and Google go our separate ways from here, unfortunately.

more options

I had the same problem, after installing FF4. I installed the latest version of G Toolbar over the old version and the problem is solved. Found a post at Google help from Nov 23, 2010.

"Google Toolbar is now compatible with Firefox 4 Beta. Google Toolbar 7.1.20101110 for Firefox is available for download..."

I did not see any version number when I downloaded and just took the easy way out - I downloaded whatever was offered.

more options

Thanks, Gizmobreaker. I just reinstalled toolbar and the problem is solved.

more options

Yup - I would consider this problem SOLVED!! Thank goodness - It was infuriating!

Like Gizmo Said - just go to Google Toolbar (http://www.google.com/toolbar/ff/index.html) and install the latest version over the top of your current one and you'll be able to click the auto suggest dropdown again!!!

more options

I just did what Gizmobreaker said and it works. Thank you Giz!

more options

This solution works on my computers with XP and Vista. However, with Windows 7 64-bit, since I installed FF4, the Google toolbar does not retain any history at all, which is very dull...I have to use the Googlear Lite toolbar to have search history. Anyone else have the same problem with the official Google toolbar, FF4 and Windows 7 64-bit?

Modified by Eloi666

more options

This gets crazier by the moment. It works on my XP machine, but I can't click on the "clear search history" link at the bottom of the box. Anyone else?

more options

For me, reinstalling Firefox fixed the dropdown problem. But "Clear search history" is also not working for me. Windows Home Premium 64-bit.

more options

Do you have Windows 7 Home Premium 64-bit? I have Windows 7 Pro 64-bit. Do you have the "No Script" extension installed? I think it causes the search history to be disabled...

more options

A work around which I have used successfully with Firefox 4 is to uninstall the main Google toolbar and to then install the Google Lite toolbar....the dropdown and search problems disappear. May not suit everyone because as the name suggests it does not have the range of extra buttons which some may like but it certainly solved the problem for me. Good luck

more options

Please try the latest Google Toolbar from toolbar.google.com, this issue should be fixed there. Also, you can choose history entry with keyboard (up/down to highlight, enter to search)

more options

OK, I've revisited this problem to finally tackle it. Others have suggested removing Google Toolbar (tools - addons - extensions - Google Toolbar - remove) and re-installing it again from new, but that never cleared the issue for me. In fact it gave me further issues, as from then on I couldn't save my button selection/preference order on google toolbar, as well as still having the issue mentioned here (unable to use mouse to choose from the auto complete list).

So here is what I did:

I backed up my Firefox bookmarks. I completely uninstalled Firefox 4 (choosing to delete ALL settings in the process) I re-installed Firefox 4 (and imported my bookmark back up file) Re-downloaded Google Toolbar.

I'm pleased to report that this totally fixed all the issues I've had...including the very annoying auto-complete issue. The only issue that remains is that the 'clear search history' link doesn't work in Google Toolbar, but I think everyone is experiencing this since Firefox 4.0 came out. I have toolbar set to not keep a search history anyway, so this doesn't bother me. So yeah, this fixed all the bad stuff for me... so if all else fails, I suggest you take my advice. Just remember to back up your precious bookmarks before you uninstall Firefox and choosing the option to save non of your settings!!!

more options

@Gizmobreaker It works!

more options

You can select items from the drop box by using the arrow keys on your keyboard and hitting enter. Not ideal but better then having to type in the whole thing.

more options

Finally, there's a way to fix this! All that you need to do is go re-download Google Toolbar, and it will work properly in Firefox 4. Download link for Google Toolbar

more options

No fix for me with Windows 7 Pro 64-bit. Still no search history with the "new" version...

more options

Well this is as bad as any problem could be for me. Unfortunately it means I'll be uninstalling Firefox for good - don't know if I'll ever go back. I can't live without Google Toolbar functions... so I'guess it's back to IE or on to Chrome.

Modified by mac2j

  1. 1
  2. 2
  3. 3