ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I don't want auto complete of usernames in gmail or other sites

  • 5 ردود
  • 169 have this problem
  • 7412 views
  • آخر ردّ كتبه jaydiefay

more options

Even now, when I registered to ask my question, as soon as I typed the first letter of my username auto complete gave me the options that have been used. I have accidentally typed a password right after a username before and now that also pops up as an option.

I have tried clearing cookies. I also tried clearing the cache, but never sure if it has worked The posts I read said to click the ok button after the clear now button. I don't have an ok button. How do I clear this and prevent it from happening again.

الحل المُختار

That behaviour happens with saved logins as well, as long as you have more than one saved for the site in question (which it sounds like you do). I still think this is what you're running into, but its possible this could also be Firefox saving your form history. See this support article for information on how to get rid of individual form entries.

To permanently disable form history, select "Firefox will: Use custom settings for history" in the Privacy options tab, then de-select "Remember search and form history". To get rid of already-saved values, go to Tools -> Clear Recent History, then select "Form & Search History" (and nothing else unless you want it deleted as well) and "Everything" for the time range to clear.

The same warning applies here: this will get rid of *all* of your saved form values.

Read this answer in context 👍 33

All Replies (5)

more options

See this support article.

Essentially, you want to open up the options window, click the security tab, then uncheck "Remember passwords for sites". If you want to get rid of passwords that have already been saved, click "Saved Passwords..." on the same tab, then remove the passwords you don't want. Make sure you either know them or have them saved somewhere else, because once you remove them you can't get them back.

more options

It isn't the passwords but the usernames that get prompted. As soon as I type in a letter every word that has been typed into a username starting with that letter appears. I cannot get rid of ANY of them. So for example if my username was susie and my password was 123, if one time I typed in susie123 all together in the username box by mistake, it is still there! So next time I go to type the letter s I can see susie123

How do I get rid of usernames from being auto prompted?

more options

Remove a saved password here:

more options

الحل المُختار

That behaviour happens with saved logins as well, as long as you have more than one saved for the site in question (which it sounds like you do). I still think this is what you're running into, but its possible this could also be Firefox saving your form history. See this support article for information on how to get rid of individual form entries.

To permanently disable form history, select "Firefox will: Use custom settings for history" in the Privacy options tab, then de-select "Remember search and form history". To get rid of already-saved values, go to Tools -> Clear Recent History, then select "Form & Search History" (and nothing else unless you want it deleted as well) and "Everything" for the time range to clear.

The same warning applies here: this will get rid of *all* of your saved form values.