ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot access secure https sites after installing Netnanny

  • 3 ردود
  • 63 have this problem
  • 5518 views
  • آخر ردّ كتبه NiteOwl12036

more options

Have been using Firefox for years. Then recently installed "net nanny" software and it changed the security settings of Firefox.

I cannot access secure https sites at all regardless of whether the net nanny software is even uninstalled.

The following alert occurs on executing Firefox ... "Could not initialize the application's security component. The most likely cause is problems with files in your application's profile directory. Please check that this directory has no read/write restrictions and your hard disk is not full or close to full. It is recommended that you exit the application and fix the problem. If you continue to use this session, you might see incorrect application behaviour when accessing security features."

Then when attempting to access a https site I get an error as follows: "Secure Connection Failed


An error occurred during a connection to support.mozilla.com.

Can't connect securely because the SSL protocol has been disabled.

(Error code: ssl_error_ssl_disabled)"

Use SSL 3.0 and Use TLS 1.0 are both selected in the "Advanced Settings"

I have also left a post on the Net nanny forum however clearly have not got a suitable answer when they talk about a setting in their software ("allow secure content") which is already activated anyway however with the software uninstalled it still didn't resolve the issue. I actually had to use IE to post to this forum.

It clearly provided a message when setting up Net nanny that it was changing the security settings when Firefox was executed for the first time for each user.

I would love to have a solution so I can get back to using Firefox as my default browser and do not believe a software application, and a well known one at that, should be making one browser non functional but not another.

All Replies (3)

more options

الحل المُختار

more options

Thanks so much. Deleting the cert8.db file was the solution. Beautiful ... back to Firefox as my default browser!

more options

I have a similar problem, posted today. I followed your instructions and deleted the cert8.db file and it was indeed recreated when the application was started. However, my problem did NOT go away.

NiteOwl12036