ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Location bar search brings up Yahoo even though about:config is set to Google.

  • 2 (ردّان اثنان)
  • 12 have this problem
  • 64 views
  • آخر ردّ كتبه toddea

more options

If I type something into the Location bar that I want to search for, a page from Yahoo or Bing comes up. I have gone to about:config as directed and keyword.url says Google search is the default. How can I get these searches to go to Google?

All Replies (2)

more options

You might want to disable or remove that Yahoo! activeX Plug-in Bridge that shows in your Installed Plugins. Firefox doesn't do ActiveX and a plugin like that might leave you open to being exploited.


First you need to figure out if an extension you have installed is causing that.

Do you have that problem when running in the Firefox SafeMode?
http://support.mozilla.com/en-US/kb/Safe+Mode
Don't select anything right now, just use "Continue in SafeMode."

If not, see this:
http://support.mozilla.com/en-US/kb/troubleshooting+extensions+and+theme...


Or, it could be caused by Malware.

Install, update, and run these programs in this order. (Not all programs detect the same Malware.) They are all free for personal use, but some have limited functionality in the "free mode" - but those are features you really don't need to find and remove the problem that you have.
Note: If your Malware infection is bad enough and you are mis-directed to URL's other than what is posted, you may have to use a different PC to download these programs and use a USB stick to transfer them to the afflicted PC.


Malwarebytes' Anti-Malware - http://www.malwarebytes.org/mbam.php
SuperAntispyware - http://www.superantispyware.com/
AdAware - http://www.lavasoftusa.com/software/adaware/
Spybot Search & Destroy - http://www.safer-networking.org/en/index.html


Or maybe your ISP is doing the redirect, but that is doubtful since you're getting two different redirect addresses (unless you are using two different ISP's).

There are two extensions that can prevent redirects:
NoRedirect:
https://addons.mozilla.org/en-US/firefox/addon/11787/

Redirect Remover:
https://addons.mozilla.org/en-US/firefox/addon/537/

more options

Well, I've tried all of these and still get the wrong search page. If anyone has a new idea, please let me know. Thanks.