Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

firefox 4.0 beta 1 always jam CPU 100% after closed for a long time

  • 1 reply
  • 30 have this problem
  • 27 views
  • آخر ردّ كتبه TXGuy

more options

When I close Firefox, the CPU usage always rise to 100% for about 1 minute and affect my working. Then I pressed CTRL+ALT+DEL and found that 'firefox.exe" still working after closed the window and usage is 100%, which slow down all my normal processes.Sometimes I need to stop the process manually.

It will not appear in 3.6 but it jam CPU seriously in 4.0 beta but I think it should be a bug and I hope it will not appear any more after final release.

This happened

Every time Firefox opened

== Firefox Closed

All Replies (1)

more options

Hanging at exit is most often caused by an Extension or a Plugin.

Kill Application In Task Manager, does firefox.exe show in the Processes tab? See: Kill Application

Causes and solutions for Firefox hanging at exit: Firefox hangs or is not responding - How to fix Firefox hangs at exit "Firefox is already running but is not responding" error - How to fix

Safe Mode You may need to use Troubleshoot Firefox issues using Safe Mode (click on "Safe Mode" and read) to localize the problem. Firefox Safe Mode is a diagnostic mode that disables Extensions and some other features of Firefox. If you are using a theme, switch to the DEFAULT theme: Tools > Add-ons > Themes before starting Safe Mode. When entering Safe Mode, do not check any items on the entry window, just click "Continue in Safe Mode". Test to see if the problem you are experiencing is corrected.

See: Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems Troubleshoot issues with plugins like Flash or Java to fix common Firefox problems Troubleshoot and diagnose Firefox problems

If the problem does not occur in Safe-mode then disable all of your Extensions and Plug-ins and then try to find which is causing it by enabling one at a time until the problem reappears. You MUST close and restart Firefox after EACH change via File > Restart Firefox (on Mac: Firefox > Quit). You can use "Disable all add-ons" on the Safe mode start window.


Other Issues: ~~red:You have installed plug-ins with known security issues. You should update them immediately.~~

Install/Update Adobe Reader for Firefox (aka Adobe PDF Plug-In For Firefox): your ver. 9.3.2; current ver. 9.3.3 (important security update release 06-29-2010; see: http://www.adobe.com/support/security/bulletins/apsb10-15.html) ~~red:Check your version here~~: http://www.mozilla.com/en-US/plugincheck/ See: http://support.mozilla.com/en-US/kb/Using+the+Adobe+Reader+plugin+with+Firefox#Installing_and_updating_Adobe_Reader You may be able to update from the Adobe Reader installed on your system instead of going to the Adobe site and downloading. Start > Program Files, find and click Adobe Reader to open, click Help, click Check for Updates. Allow the download/update to occur. If you use this method, no need to proceed with the instructions below, but do look at the two bulleted items at the bottom "NOTE for IE:" and "Also see:". Restart Firefox and check your new version here: http://www.mozilla.com/en-US/plugincheck/ If you go to the Adobe site to download the current Adobe Reader: -use Firefox to download and SAVE to your hard drive (save to Desktop for easy access) ~~red:-See the images at the bottom left of this post to see the steps to take on the Adobe site~~ -exit Firefox (File > Exit) -check to see that Firefox is completely closed (Ctrl+Alt+Del, choose Task Manager, click Processes tab, if "firefox.exe" is on the list, right-click "firefox.exe" and choose End process, close the Task Manager window) -double-click on the Adobe Reader installer you just downloaded to install/update Adobe Reader