X
Tap here to go to the mobile version of the site.

منتدى الدعم

Google search displays strange characters before search, firefox 3.6.7, ubuntu 10.04

Posted

I get these strange characters when I go to Google search using Firefox 3.6.7 and Ubuntu 10.04.......see below ᎢᏳᏍᏗ ᎨᏒ ᎣᏲᎲᎢᎠᏑᏰᏍᏗ ᏳᏍᏗ ᎠᏁᎵᏔᏅ (These characters are on the Google search page before I search and below search bar. strange characters below: ᎾᏍᎩᏯᎢ Directory ᏚᎾᏓᏡᎬ What is going on....It reads OK using Chromium. I can't read anything. I am using Firefox 3.6.7. My View....character encoding is set to : Western(ISO-8859-1) and auto detect "on"

== ?

I get these strange characters when I go to Google search using Firefox 3.6.7 and Ubuntu 10.04.......see below ᎢᏳᏍᏗ ᎨᏒ ᎣᏲᎲᎢᎠᏑᏰᏍᏗ ᏳᏍᏗ ᎠᏁᎵᏔᏅ (These characters are on the Google search page before I search and below search bar. strange characters below: ᎾᏍᎩᏯᎢ Directory ᏚᎾᏓᏡᎬ What is going on....It reads OK using Chromium. I can't read anything. I am using Firefox 3.6.7. My View....character encoding is set to : Western(ISO-8859-1) and auto detect "on" == ?

Additional System Details

Installed Plug-ins

  • -Xine Plugin version 1.0.2, (c) The Xine Project.Windows Media Player / RealPlayer / QuickTime compatible.
  • Helix DNA Plugin: RealPlayer G2 Plug-In Compatible version 0.4.0.5174 built with gcc 4.1.2 on Oct 6 2009
  • The IcedTea NPR Web Browser Plugin (using IcedTea6 1.8 (6b18-1.8-0ubuntu1)) executes Java applets.
  • The Totem 2.30.2 plugin handles video and audio streams.
  • DivX Web Player version 1.4.0.233
  • This plug-in detects the presence of iTunes when opening iTunes Store URLs in a web page with Firefox.
  • Shockwave Flash 10.1 r53

Application

  • User Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.7) Gecko/20100715 Ubuntu/10.04 (lucid) Firefox/3.6.7

More Information

Application Basics
Name
Firefox
Version
3.6.7
Profile Directory
Open Containing Folder
Installed Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Ubuntu Firefox Modifications 0.9rc2 true ubufox@ubuntu.com
Modified Preferences
Name
Value
accessibility.blockautorefresh false
accessibility.browsewithcaret false
accessibility.typeaheadfind false
accessibility.typeaheadfind.linksonly false
browser.history_expire_days 180
browser.history_expire_days.mirror 180
browser.history_expire_days_min 90
browser.link.open_newwindow 3
browser.places.importBookmarksHTML false
browser.places.smartBookmarksVersion 2
browser.startup.homepage http://verizon.my.yahoo.com/
browser.startup.homepage_override.mstone rv:1.9.2.7
browser.tabs.autoHide false
browser.tabs.closeButtons 1
browser.tabs.loadInBackground true
browser.tabs.tabMaxWidth 250
browser.tabs.tabMinWidth 100
browser.tabs.warnOnClose false
browser.tabs.warnOnOpen true
dom.disable_open_during_load true
dom.disable_window_flip true
dom.disable_window_move_resize false
dom.disable_window_open_feature.status true
dom.disable_window_status_change true
dom.event.contextmenu.enabled true
extensions.lastAppVersion 3.6.7
javascript.enabled true
network.cookie.cookieBehavior 0
network.cookie.lifetimePolicy 0
network.cookie.prefsMigrated true
places.last_vacuum 1279754533
privacy.clearOnShutdown.cache true
privacy.clearOnShutdown.cookies true
privacy.clearOnShutdown.downloads true
privacy.clearOnShutdown.formdata true
privacy.clearOnShutdown.history true
privacy.clearOnShutdown.offlineApps false
privacy.clearOnShutdown.passwords false
privacy.clearOnShutdown.sessions true
privacy.clearOnShutdown.siteSettings false
privacy.cpd.cache true
privacy.cpd.cookies true
privacy.cpd.downloads true
privacy.cpd.formdata true
privacy.cpd.history true
privacy.cpd.sessions true
privacy.cpd.siteSettings false
privacy.sanitize.migrateFx3Prefs true
privacy.sanitize.sanitizeOnShutdown false
privacy.sanitize.timeSpan 0
security.OCSP.enabled 1
security.OCSP.require false
security.default_personal_cert Ask Every Time
security.enable_ssl3 true
security.enable_tls true
security.warn_entering_secure false
security.warn_entering_weak true
security.warn_leaving_secure false
security.warn_submit_insecure false
security.warn_viewing_mixed false

Question owner

I am having the same issue as roy gavilan. I am using Ubuntu 10.04 (x64) with Firefox 3.6.7. See screenshot for a better idea.

I am having the same issue as roy gavilan. I am using Ubuntu 10.04 (x64) with Firefox 3.6.7. See screenshot for a better idea.
cor-el
  • Top 10 Contributor
  • Moderator
17539 solutions 158588 answers
That is Cherokee: http://en.wikipedia.org/wiki/Cherokee_syllabary

Question owner

Maybe you should go to Google's front page, and at the bottom, it says "show in English" or something of the sort.

Maybe you should go to Google's front page, and at the bottom, it says "show in English" or something of the sort.

Question owner

I checked preferences and it was not set to American. I changed it to American and then I still got a bunch of weird characters. I went back and changed it to French and them went back and changed it to englaise and I'm now OK.....go figure. I have never had to set the language in Google before. I thought your solution was too simple and would not work. Thanks

I checked preferences and it was not set to American. I changed it to American and then I still got a bunch of weird characters. I went back and changed it to French and them went back and changed it to englaise and I'm now OK.....go figure. I have never had to set the language in Google before. I thought your solution was too simple and would not work. Thanks

Question owner

Should be I set it anglais....typo

Should be I set it anglais....typo

Question owner

I installed updates to Ubuntu this morning and now I have the same problem again....I believe they were java and icedtea updates. English or USA are not even listed as a language choice.

I installed updates to Ubuntu this morning and now I have the same problem again....I believe they were java and icedtea updates. English or USA are not even listed as a language choice.

Question owner

I decided to run "firefox -safe-mode" (Alt+F2).

Then I checked "Reset all user preferences to Firefox defaults". Things look OK now.

I decided to run "firefox -safe-mode" (Alt+F2). Then I checked "Reset all user preferences to Firefox defaults". Things look OK now.
gualter666 0 solutions 1 answers

I solved it by entering the google page configuration (right top corner), then search configuration. In the interface language menu was setted afrikaans. I couldn't find spanish (my language) or english, so i choose portuguese. Then, from the google main page (in portuguese, you can translate if don't understand) repeat the process and now there were all the languages, choose spanish, and problem solved.

I solved it by entering the google page configuration (right top corner), then search configuration. In the interface language menu was setted afrikaans. I couldn't find spanish (my language) or english, so i choose portuguese. Then, from the google main page (in portuguese, you can translate if don't understand) repeat the process and now there were all the languages, choose spanish, and problem solved.
shushboy 0 solutions 1 answers

This worked for me as well. In my case, the dialog to reset preferences to defaults did not appear unless I closed all Firefox windows before executing 'firefox -safe-mode' .

There must be something funny going on in the about:config page Ubuntu released.

This worked for me as well. In my case, the dialog to reset preferences to defaults did not appear unless I closed all Firefox windows before executing 'firefox -safe-mode' . There must be something funny going on in the about:config page Ubuntu released.
nakor 0 solutions 2 answers

I've just had this same problem. Resetting user preferences works fine.

This may not be true for everyone but the issue for me is being caused by Firefox Sync. I'm guessing (haven't had time to properly test) this is due to the fact that I'm syncing between Ubuntu (10.04) and Windows (XP and 7).

I can still use Firefox Sync but just have to disable preferences syncing on Ubuntu. If I get time I'll test it the other way (i.e. initial sync on Ubuntu and then sync those prefs to Windows).

On another note, the fix mentioned above about changing Google preferences is no good if you clear cookies etc. when closing Firefox as this removes any changes you make to the Google preferences and it defaults back to the incorrect settings.

I've just had this same problem. Resetting user preferences works fine. This may not be true for everyone but the issue for me is being caused by Firefox Sync. I'm guessing (haven't had time to properly test) this is due to the fact that I'm syncing between Ubuntu (10.04) and Windows (XP and 7). I can still use Firefox Sync but just have to disable preferences syncing on Ubuntu. If I get time I'll test it the other way (i.e. initial sync on Ubuntu and then sync those prefs to Windows). On another note, the fix mentioned above about changing Google preferences is no good if you clear cookies etc. when closing Firefox as this removes any changes you make to the Google preferences and it defaults back to the incorrect settings.
nakor 0 solutions 2 answers

Helpful Reply

Just to update this topic if anyone else has the issue. I've fixed it by manually amending the following setting in about:config -

Preference name: intl.accept_languages

Value: en-gb, en

If you're in the US you'd use en-us, en instead.

I then re-ran Firefox Sync and now on the Windows machines this value shows up as User Defined instead of default and this is now kept when syncing (I'm assuming the default values are not included when syncing preferences, for obvious reasons).

Just to update this topic if anyone else has the issue. I've fixed it by manually amending the following setting in about:config - Preference name: intl.accept_languages Value: en-gb, en If you're in the US you'd use ''en-us, en'' instead. I then re-ran Firefox Sync and now on the Windows machines this value shows up as User Defined instead of default and this is now kept when syncing (I'm assuming the default values are not included when syncing preferences, for obvious reasons).

Modified by nakor

crypto 0 solutions 1 answers

Helpful Reply

This fixes it all for me. No point fiddling with about:config, etc

Edit->Preferences->Content->"Choose..." (under Languages)

Remove the language that's there (or languages) Select your language and click "add" , "OK"

Restart Firefox - that should work.

This fixes it all for me. No point fiddling with about:config, etc Edit->Preferences->Content->"Choose..." (under Languages) Remove the language that's there (or languages) Select your language and click "add" , "OK" Restart Firefox - that should work.

Modified by crypto

Superpelican 0 solutions 1 answers

I'm running wattOS Linux R3 which is Ubuntu and Debian based. I'm using Firefox 4.0.1 and the problem only appears on the Dutch iGoogle page, not on the English version. You can see picture of the problem.

I'm running wattOS Linux R3 which is Ubuntu and Debian based. I'm using Firefox 4.0.1 and the problem only appears on the Dutch iGoogle page, not on the English version. You can see picture of the problem.