ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Visited Links Do Not Change Color

  • 10 ردود
  • 237 have this problem
  • 6603 views
  • آخر ردّ كتبه Rich Pasco

more options

My visited links do not change color.

All Replies (10)

more options
  • Make sure that you do not use Delete browsing, search and download history on Firefox to clear the Browsing History.
  • Make sure that the History is set to at least 1 day: Tools > Options > Privacy > History: "Remember visited pages for at least"
  • Make sure that you do not start Firefox in Private Browsing mode (Tools > Stop Private Browsing is grayed, see Private Browsing - Use Firefox without saving history)
  • To see History and Cookie settings in Tools > Options > Privacy, choose the setting "Firefox will: Use custom settings for history"

You can look at these prefs on the about:config page. http://kb.mozillazine.org/browser.history_expire_days (180) (also affects saved form data) http://kb.mozillazine.org/browser.history_expire_days_min (90)

To open the about:config page, type about:config in the location (address) bar and press the Enter key, just like you type the url of a website to open a website. If you see a warning then you can confirm that you want to access that page.

more options

a mi me paso en mandriva linux y esta fue la solucion:

you can revert this change by typing about:config in Firefox
address bar then pressing Enter, search for 

layout.css.visited_links_enabled and double click it to change it to true.

tomado de:

http://wiki.mandriva.com/en/2010.0_Errata#Firefox_doesn.27t_change_the_colour_of_visited_links

more options

I have the same problem. If I un-check content > colors > "Allow pages to choose its own colors, instead of my selections", then I am able to choose my own colors for visited links. But web pages now look horrible.

I would like web pages themselves to use their own colors, but when I do a Google search, I would like my visited links to show up in a color I choose. As it is, there is very little difference between the default colors for visited links and non-visited links.

On the privacy tab I have everything checked except for Automatic start private, and Clear history when FF closes.

more options

You can use code in userContent.css to set the color(s) for text and background to make the appearance of the visited links more outstanding.

You can add this code to userContent.css: (change the colors as you like)
Code like this can cause problems with pages that use background images for links.
This code only works on the Google.com domain.

@-moz-document domain(google.com) {
 a:visited {
  color:#FF00CC !important;
  background-color:#E8E8E8;
 }
}


A generic code would be:

 a:visited {
  color:#FF00CC !important;
  background-color:#E8E8E8;
 }
more options

Thanks. I'll give it a try. But, this seems like a work-around for a basic Firefox problem. Guess that means there is no general solution, right?

I tried setting the tools>options>privacy to Remember History (from Use Custom Settings), but it always reverts to Custom settings. Several posts hinted that that might be the problem. I'm thinking that my settings are not being recorded properly, although the pref.js file has "user_pref("browser.visited_color", "#FF9900"); which is what I set, so, it seems that my preferences are being set correctly.

Thanks for the reply. I'll report the results.

more options

I searched for a userContent.css file on my system, but no joy. Where should I make such a file, and what would be the entire contents?

more options

You can rename the example file userContent-example.css to userContent.css in the chrome folder in the Firefox Profile Folder and add one of the versions of the above posted code at the end of the file.

See http://kb.mozillazine.org/Editing_configuration

You can also look at the Stylish extension.

more options

cor-el: Thanks so much for the advice. Making the userContent.css file did the trick, and I am now able to select what colors my visited links appear as. Blessings to you, and have a great Thanksgiving.

more options

Firefox 11.0 has stopped updating which links are colored as visited and which ones aren't. When I visit any web page (which assigns different colors for visited links) some of them are the unvisited color, some are the visited color, as I might expect. However, if I click on all those links and then reload the original page, nothing has changed: those links which were the visited color are still the visited color, and those links which were the unvisited color are still the unvisited color. Nothing I do seems to change this.

My setting for Tools/Options/Privacy is "Remember History." But it won't highlight the most recently visited links as I would expect.

Even after I clear my history by Tools/Clear Recent History, checking Browsing and Download History, the same set of links are the visited color as they were before.

How can I restore Firefox' ability to remember newly visited links and forget the old ones?

more options

In my case the problem turned out to be a corrupt bookmark file! I was able to fix it by restoring my bookmarks from a backup of few days ago. To do this, I pulled down the Bookmarks menu and chose "Show All Bookmarks." On the Library window which opened, I chose "Import and Backup" and then "Restore" and chose a date about five days ago. I confirmed a willingness to replace all my bookmarks.... Having done so, I found that Firefox again began correctly keeping track of visited links. Firefox works in mysterious ways. Go figure.

Modified by Rich Pasco