ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox giving XML parse errors all of a sudden; fails to start

  • 4 ردود
  • 41 have this problem
  • 809 views
  • آخر ردّ كتبه speleo01

more options

Starting Firefox on Centos 5.5 (i386) fails, with error popup: XML Parsing error: error in processing external entity reference Location: chome://browser/content/browser.xul Line number 15, column 1

All Replies (4)

more options

This may be a problem with an add-on.

Try Diagnose Firefox issues using Troubleshoot Mode

If the problem disappears it's an add-on - try disabling them to see which it is.

more options

Safe mode does not fix the issue, nor does uninstalling firefox, removing all traces from the system and reinstalling.

Version installed from CentOS repositories:3.6.4-8.el5.centos

more options

I don't know what this is. I would suggest a lot of googling and asking on Centos forums.

Have you tried setting up a new profile - see Troubleshoot and diagnose Firefox problems

Does it happen whenever you start up? Was this an upgrade from a previous version? If so I wonder if there's a dependency problem in the Centos rpm - perhaps a mismatch with xulrunner. You could try reinstalling xulrunner (or updating it if there's a later version). I had a similar problem with SUSE rpms recently.

Or you could try installing the Mozilla tgz for comparison. If you do that set up a new profile and keep the two versions separate (or uninstall the Centos one)

That's all I can think of for now.

more options

I recently had this problem and noticed that the "Work Offline" option had somehow been checked (in the drop-down menu when Firefox is clicked in the uppermost left corner of the page)...I unchecked that and the errors disappeared.