Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I get rid of these strange characters: Now apparently you are turning to be a real person with real emotions and less pose and smart…s comments. Keep going. Please no more “working families”, “Australian people” “working Australian

  • 11 replies
  • 49 have this problem
  • 16081 views
  • آخر ردّ كتبه cor-el

more options


   Now apparently you are turning to be a real person with real emotions and less pose and smart…s comments. Keep going. Please no more “working families”, “Australian people” “working Australians” “mums and dads! The mention” for the people of this great country” is more than enough!

Comment 13 of 59

This happened

A few times a week

== months ago

Chosen solution

In Tools>Options>Content

Locate the Advanced button under "Fonts & Colours"

Uncheck the box that says "Allow pages to choose their own fonts, instead of my selection above"

When websites use fonts that you do not have installed or Firefox cannot read properly you will see the hex codes for the letters, by unchecking that box you will see the text displayed in fonts you have installed on your computer and in your browser.


Regards



Craig

Read this answer in context 👍 1

All Replies (11)

more options

Where do you see that text?

more options

i get sometimes embedded in a post-variable in php a "Â" -character; i.e instead of "name" there is "naÂme" ; after firefox restart most of the times the  does not appear anymore. Very difficult to reproduce.

more options

If you see an  then that is probably an error with a wrong content type received by Firefox. You can verify that in View > Character Encoding

An  indicates that the text is UTF-8 encoded. It is possible that your firewall or other security software is causing problems and is corrupting the headers received from the server causing Firefox to use the default encoding (Western ISO-8859-1)

more options

Chosen Solution

In Tools>Options>Content

Locate the Advanced button under "Fonts & Colours"

Uncheck the box that says "Allow pages to choose their own fonts, instead of my selection above"

When websites use fonts that you do not have installed or Firefox cannot read properly you will see the hex codes for the letters, by unchecking that box you will see the text displayed in fonts you have installed on your computer and in your browser.


Regards



Craig

more options

Thanks Craig,

This has been a real aggravation to me for a long time...

Gary

more options

I have this exact same problem. It started when I visited a web site from a google search. The resulting web page displayed the strange quadrant/box characters on the page title line at the top. I've had this problem since and none of the suggestions here appear to correct the problem. Pages that have always displayed correctly, e.g. Yahoo Finance company summary page, now displays these odd characters in certain spots, and these incidents are consistent and repeatable ... Hey tech wizards, any other suggestions?

more options

One other observation. Per cor-el's posts, a page with these characters is displaying using Unicode UCC-8 but changing the character encoding to Western ISO-8859-1 simply changes the odd characters to a different odd characters.

more options

Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot and make sure that you do not exceed the maximum file size (1 MB).

Are those web pages using the Helvetica font?

more options

Hello cor-el, Thanks for looking at this.

I don't believe the font is Helvetica; probably Arial. I notice that all of my pages display in UTF-8, even tho' the default is supposed to be ISO-8859-1. Don't know what that means or if that's out of the ordinary.

The attached problem sample is from a Yahoo Finance summary screen for the ETF investment instrument "DLN" - this is a repeatable problem. The rest of the screen appears normal and doing a "Get Quotes" look-up for other investments does not generate the same problem.

more options

More observations ... I get the same odd characters using Explorer and with Safari on a MacBook. I'm using an AT&T DSL connection. I wonder if others of you get the same odd characters in the "funds summary" section if you go to finance.yahoo.com and do a "get quotes" inquiry on "DLN"...

more options

The default is only used when the web server doesn't send an encoding.

If you see those strange characters even with UTF-8 selected then it is likely a problem with that specific page and may be caused by copying data from a Windows-1252 source and pasting it in an Unicode document and in that case there is nothing that you can do about it.

That part (0x80-0x9f) of the Unicode map is not supposed to be used (it has control characters)