Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

HIde pinned tabs problem

  • 13 ردًا
  • 0 have this problem
  • 8 views
  • آخر ردّ كتبه noel_envode

more options

I was set up, in myuserchrome.css, to hide my pinned tabs on the tab bar, allowing them to still be available in the "List all tabs" menu, see first image

.tabbrowser-tab[pinned="true"] { display: none !important;}

All of a sudden, it reverted back

That first image, with the hidden tabs, is actually from Librewolf, with has the identical setting.

I was set up, in myuserchrome.css, to hide my pinned tabs on the tab bar, allowing them to still be available in the "List all tabs" menu, see first image .tabbrowser-tab[pinned="true"] { display: none !important;} All of a sudden, it reverted back That first image, with the hidden tabs, is actually from Librewolf, with has the identical setting.
Attached screenshots

All Replies (13)

more options

pinned was one of the attibutes that used to be a pseudo Boolean (i.e. an attribute with a string value). A lot of such pseudo Boolean attributes have been converted to a real Boolean, so best is to avoid using ="true" and simply use [pinned].

.tabbrowser-tab[pinned] {display: none !important;}
more options

I just discovered what happened.

Apparently, after I updated to Fx v118.0, it changed my settings, to auto-update, which means I not only unknowingly get auto-updated, but I get bumped my up to 119.02 beta. without a notification or user confirmation prompt.

Now, the sequence of events that I experienced make sense. I was browsing, and all of sudden the Fx interface kinda "blinked", and all my pinned tabs suddenly reappeared on my tab bar. No auto restart, no notification of any kind, and now I an unwitting became a beta tester.

I reverted back to v118.0, disabled the auto update, everything's back to normal. and thanks to you,

.tabbrowser-tab[pinned] {display: none !important;}

work for v119. so you helped me avoid the future chore of seeking an answer for that.

Thanks again

more options

You can't switch the update channel by updating, this is only possible by installing the full version. So you must already have been on the Beta or Developer Edition (aurora) update channel to get the 119.0b1/b2 release. These developer builds update twice per week with Beta getting the release candidates (RC) builds where DE halts updating after the last update for a branch (118.0b9).

more options

This is what I know. This is my main profile.

I've utilized the Firefox Profile manager, for many years now.

Using Release, ESR, Beta, Aurora, and/or Nightly together

I use an extracted/portable version of the Firefox executable, with auto updating disabled.

The only other time I saw symptoms like this was after Quantum was released

The shortcut that initializes the Profile manager is from the executable in my Firefox stable installation folder.

One thing in particular that troubles me (see image) is the fact that instead of establishing the next stable release as the default upgrade, it's the beta.

What am I not understanding about that?

Modified by noel_envode

more options

What is the update channel (Help -> About Firefox or about:support) of each version ?

more options

I don't know what you mean by each version

more options

I mentioned 'each version' for the case that you have multiple Firefox versions installed. The first screenshot shows that you are on the beta update channel and that means that you get updates twice per week, on the about:support page you can find this further down just above the user agent.

more options

I didn't notice that until you mentioned it. I don't have anything "installed" in the classic sense anyway. it's all portable, all stable.

Under these circumstances, isn't there a way to get off that beta channel?

Modified by noel_envode

more options

Go to about:config in the address bar and make sure that app.update.channel is release.

more options

You can only switch the update channel by installing the full version and insure that channel-prefs.js is replaced.

more options

cor-el said

You can only switch the update channel by installing the full version and insure that channel-prefs.js is replaced.
The problem for me is, I want it portable. I don't want to install.

app.update.channel = beta, there was no option to change it to release unless done manually, which I tried, but still shows this

And I assume editing this to release is not an option, or a solution since it's the same thing as dong it in about:config?

"/* This Source Code Form is subject to the terms of the Mozilla Public

* License, v. 2.0. If a copy of the MPL was not distributed with this
* file, You can obtain one at http://mozilla.org/MPL/2.0/. */

// // This pref is in its own file for complex reasons. See the comment in // browser/app/Makefile.in, bug 756325, and bug 1431342 for details. Do not add // other prefs to this file.

pref("app.update.channel", "beta");"

Modified by noel_envode

more options

The app.update.channel is just to show what channel you are on as changing it in about:config has no effect.

more options

I decided to try one more thing. I went to Index of /pub/mozilla.org/firefox/releases, to make sure I had the right 118.01 release executable.

I extracted it, and used that to replace the contents of my current release install directory.

Guess I should have taken your advice more literally about "installing" the latest release version

Just for the sake of conversation, I also updated my beta directory to 119.03, but unlike what was happening before, there are no references to the stable 118.01.

Wish I knew what caused the initial mess??

Modified by noel_envode