Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox won't open .pdfs in Acrobat

more options

I have always read downloaded .pdf files in Acrobat. I inadvertently changed the setting to "Open in Firefox" (I got a prompt and clicked it without intending to). I have changed the preference back to "Use Adobe Acrobat" in Settings/General/Applications, but Firefox keeps opening pdfs in a browser window. How do I get Firefox to abide by my preference setting?

I have always read downloaded .pdf files in Acrobat. I inadvertently changed the setting to "Open in Firefox" (I got a prompt and clicked it without intending to). I have changed the preference back to "Use Adobe Acrobat" in Settings/General/Applications, but Firefox keeps opening pdfs in a browser window. How do I get Firefox to abide by my preference setting?

الحل المُختار

Thanks for your quick response!

I was opening them by clicking on the file icons (which changed appearance when it went to browser opening). After I sent the inquiry I got a pop-up while in Acrobat asking if I wanted to set the latter to my default pdf app; I clicked yes, and it changed it.

So if something like this happens again I know to go to WFE default apps. But: Why didn't changing the preference within Firefox work?

NB: My problem is solved but on this screen I seem to be able to either reply, or report problem solved, but not both. It's solved.

Read this answer in context 👍 0

All Replies (3)

more options

Are you opening them from the Downloads button drop-down list, or from the folder where they were saved (Windows File Explorer)?

If the problem is the downloads list, use right-click > Always Open in Acrobat

If the problem is in Windows File Explorer, you need to go into the default apps control panel to reset .pdf to Acrobat.

If neither of those works, is the website using its own previewer instead of sending Firefox the PDF?

more options

الحل المُختار

Thanks for your quick response!

I was opening them by clicking on the file icons (which changed appearance when it went to browser opening). After I sent the inquiry I got a pop-up while in Acrobat asking if I wanted to set the latter to my default pdf app; I clicked yes, and it changed it.

So if something like this happens again I know to go to WFE default apps. But: Why didn't changing the preference within Firefox work?

NB: My problem is solved but on this screen I seem to be able to either reply, or report problem solved, but not both. It's solved.

more options

Changing the setting within Firefox should fix how Firefox opens PDFs from websites, but it doesn't change what Windows does when you launch a PDF in Windows File Explorer.