ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Resizing of tabs and open new tab plus icon do not work correctly

  • 8 ردود
  • 0 have this problem
  • 86 views
  • آخر ردّ كتبه bernhard41

more options

Since one of the last updates the behaviour for the tab re-sizing got messed up.

When there are only a few tabs with full size, those as well as the additional plus icon is shown. But when there are more tabs and they are re-sized, then the right side gets cut off. First the new tab icon dissapears and then also the last tab get's cut off.

I attached a screenshot with three firefox browser windows showing the problem, as well as a forth one with only 3 tabs open, which are shown in full size including the new tab icon.

This is a new problem as the tab resizinng and the new tab icon used to work perfectly fine no matter how many tabs were opened.

Since one of the last updates the behaviour for the tab re-sizing got messed up. When there are only a few tabs with full size, those as well as the additional plus icon is shown. But when there are more tabs and they are re-sized, then the right side gets cut off. First the new tab icon dissapears and then also the last tab get's cut off. I attached a screenshot with three firefox browser windows showing the problem, as well as a forth one with only 3 tabs open, which are shown in full size including the new tab icon. This is a new problem as the tab resizinng and the new tab icon used to work perfectly fine no matter how many tabs were opened.
Attached screenshots

الحل المُختار

Are you using userChrome.css because a possible cause is a broken userChrome.css that needs updated code ?

If you have this rule, then comment it out as it is no longer needed.

/* TABS: width - [65-107] */
/*
 #tabbrowser-tabs { width: 100vw !important; }
*/

Read this answer in context 👍 0

All Replies (8)

more options

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.

  • switch to the Default System theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window
more options

Hi,

in troubleshoot mode tabs and new tab icon shows correctly indeed!

But that only solves the problem when I stay in troublshoot mode forever.. : (

I don't have any themes installed. (the automatic system theme is active)

And I have hardly any addons (Easy Screenshot and foxy Gestures) installed. And even when I deactivate them, the problem remains.

So the question now is, what is causing those issues?

more options

الحل المُختار

Are you using userChrome.css because a possible cause is a broken userChrome.css that needs updated code ?

If you have this rule, then comment it out as it is no longer needed.

/* TABS: width - [65-107] */
/*
 #tabbrowser-tabs { width: 100vw !important; }
*/

more options

not that I am aware of.. I don't knonw what that is and unless it's a default part of the browser, I didn't use/install anything like that.

more options

What's the difference between troubleshoot and regular mode?

I mean since it's working in troubleshoot mode, could I simply stay in that mode permanently? Or do important features not work there?

more options

Firefox normally shows your tabs ABOVE the address bar. Since your screenshots show that yours are BELOW the address bar, then most likely at some point you (or someone you share your computer with) set up a userChrome.css file with style rules that rearrange the orders of the toolbars. From time to time, these rules break in unpredictable ways as the developers evolve the toolbar layout. That is what we suspect is happening in your case.

Do you care whether the tabs are ABOVE or BELOW the address bar?

If not:

You can set Firefox back to ignoring your userChrome.css file this way:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future. Since we are restoring the default here, I feel comfortable mentioning it.

(2) In the search box in the page, type or paste userprofile and pause while the list is filtered

(3) If the toolkit.legacyUserProfileCustomizations.stylesheets preference is bolded and "modified" to true, double-click it (or click the Reset arrow button at the right end of the row) to restore the default value of false

That should take effect the next time you do a normal exit of Firefox and start it up again.

If you DO want tabs BELOW the address bar:

Then you will need to edit your userChrome.css file to work with Firefox 110+. cor-el would have a better idea of what is wrong than I would.

more options

jscher2000 - Support Volunteer schrieb

Firefox normally shows your tabs ABOVE the address bar. Since your screenshots show that yours are BELOW the address bar, then most likely at some point you (or someone you share your computer with) set up a userChrome.css file with style rules that rearrange the orders of the toolbars. From time to time, these rules break in unpredictable ways as the developers evolve the toolbar layout. That is what we suspect is happening in your case. If you DO want tabs BELOW the address bar: Then you will need to edit your userChrome.css file to work with Firefox 110+. cor-el would have a better idea of what is wrong than I would.

Hi Jscher2000,

ah, yes, you are spot on! That's correct, I do want/need those tabs below the address bar.. Drives me crazy to have them above.. I don't know how I achieved that, I probably searched for how to get it below and followed whatever instructions I found. I can't remember what those were precisely.

So I'll have to try to find a new, working way to have them below AND working correctly... I guess there should be an updated way to have them shown below and still work correctly..

When I look for that now, all I find are long threads of users complaining that there is no solution for that and obviously mozilla does not care to offer this feature.. Very annoying.. : (

Modified by bernhard41

more options

cor-el schrieb

Are you using userChrome.css because a possible cause is a broken userChrome.css that needs updated code ? If you have this rule, then comment it out as it is no longer needed.
/* TABS: width - [65-107] */
/*
 #tabbrowser-tabs { width: 100vw !important; }
*/

Hi,

I completely forgot that showing the tabs BELOW the address bar is quite an (ongoing) issue by itself. I defenitely need that and obviously I did follow some instructions along the way long time ago to make that happen. So I guess I did create that chrome css file back then. I completely forgot about that and I also have no idea how to find and to that. But I did some research now, found it, got rid of that section pointed out by cor-el and so far it looks like 1. my tabs remain BELOW the address bar - the one and only place where they do belong in my opinion 2. the tabs seem to resize correctly, as well as the new tab plus icon is shown at the end corretly too!

Thx to Cor-el and Jscher2000 for pointing me into the correct direction!