ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Problem with my bank 2FA and firefox

  • 8 ردود
  • 1 has this problem
  • 17 views
  • آخر ردّ كتبه tsb

more options

Am using FF 109.01 (64) and the latest Windows 10 (64) ver. I uses their Virus program.

With my bank security settings I have check marked to not use 2FA Bank home page asks for a security code anyway.

This has happened to me months ago and all of a sudden everything was OK. ... and now it has happened again. When I use Edge, Bank home page does not ask for a security code. This is the way I would like FF to perform.

I have phoned the Bank IT Help desk and they are bafflled. They had me try a bunch of acrobats but nothing works.

Obviously there is something in FF to tweak. I am using

I have searched and searched on internet, but no solution. I have used FF since it was a baby, and I want to stick with it. Thanks

Am using FF 109.01 (64) and the latest Windows 10 (64) ver. I uses their Virus program. With my bank security settings I have check marked to '''not '''use 2FA Bank home page asks for a security code anyway. This has happened to me months ago and all of a sudden everything was OK. ... and now it has happened again. When I use Edge, Bank home page does not ask for a security code. This is the way I would like FF to perform. I have phoned the Bank IT Help desk and they are bafflled. They had me try a bunch of acrobats but nothing works. Obviously there is something in FF to tweak. I am using I have searched and searched on internet, but no solution. I have used FF since it was a baby, and I want to stick with it. Thanks

All Replies (8)

more options

Thanks for your reply Dropa. My bank has a list of approved browsers, Firefox, being 1 of about 5.

I have had to use Edge also for some forms I fill out for the government of Canada and for our Province.

Odd that Firefox was working and then it wasn't and then it was. I remember calling the IT desk at the bank website and the lady said that there were other people with the same complaint.

more options

Dropa asked me what virus program I use, I forgot to mention. It is the built-in antivirus and firewall program in Windows 10: Windows Defender

more options

It could be that you do not keep the session cookie that makes the bank recognize you.

Detail like websites remembering you and log you in automatically is stored in cookies, so make sure you aren't clearing important cookies.

You can use these steps to make a website recognize and remember you.

  • create a cookie allow exception with the proper protocol (https:// or http://) to make a website remember you

You can check that you aren't clearing important cookies.

  • using "Delete cookies and site data when Firefox is closed" to clear cookies keeps cookies with an allow exception
    in 102+ version toggling this setting makes changes to the "Clear history when Firefox closes" settings and those settings prevail
  • using "Clear history when Firefox closes" in Firefox 102+ honors exceptions and keeps cookies with an allow exception, previous versions removed all cookies

Make sure to keep the "Site settings".

  • clearing "Site settings" clears exceptions for cookies, images, pop-up windows, and software installation and exceptions for passwords and other website specific data
  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Exceptions"
  • Settings -> Privacy & Security
    Firefox will: "Use custom settings for history":
    [X] "Clear history when Firefox closes" -> Settings
more options

Thanks cor-el.

Still won't exclude 2FA

I am tempted to try on another computer keeping in mind that the bank website will do 2FA the first time I try it.

more options

Some bank sites send a security code via email as an extra security measure. Could that be happening in your case ?

Like I posted above, if you do not keep the bank's cookies then you will required to repeat this procedure.

more options

Thanks for answering again, my bank doesn't send a security code by email. I am certain that I keep the bank's cookies when I exit. I double-checked my settings in "Privacy and Security" asyou suggested I do.

Remember that it worked before, I haven't changed anything.

Puzzling?

more options

aha! I discovered when I login to my other accounts at the same bank I don't have do TFA (they are all set to no TFA).

It only requests TFA with the one problem account.

Where is the error? The bank or Firefox?

Maybe I should try running another version of Firefox and see what happens.

more options

Just tried by downloading Firefox nightly. Same problem. It is the fault of the bank. My conclusion .