ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Youtube and Google Images loading forever

  • 7 ردود
  • 0 have this problem
  • 8 views
  • آخر ردّ كتبه cor-el

more options

So currently im having a problem where my browser (Firefox 106.0.5 (64-bit)) take forever to load youtube and google images. Everytime i open youtube.com it doesn't show the sidebar (first image), then when i watch a video, it get stuck forever (second image), but when i reload it, it load the video but the comments are stuck loading forever(third image), and it also happen to pretty much all the youtube pages, everytime i navigate to other youtube's pages, it get stuck, then i reload it, then its half working, some still stuck forever.

In google images, everytime i click a result from the searches (i click the first cat/fourth image), it just showing blank (fifth image)

I already try to turn on/off extensions, remove them, clear cache, clear cookies, try the private window, it still doesn't resolve the problem

I check my internet connection, it working just fine, i can access other websites without problem, i try to open in other browser (edge), it work just fine too, it just happen on my firefox and specifically only on youtube and google images

i try use vpn/dns stuff, still doesn't work, i have no idea what is wrong with my browser, so please someone help me fix this problem since firefox is my default (and favorite) browser and i also rely on the two websites for working daily, thank you

tldr; firefox take forever to load youtube & google images, please help me i have no idea what to do

So currently im having a problem where my browser (Firefox 106.0.5 (64-bit)) take forever to load youtube and google images. Everytime i open youtube.com it doesn't show the sidebar (first image), then when i watch a video, it get stuck forever (second image), but when i reload it, it load the video but the comments are stuck loading forever(third image), and it also happen to pretty much all the youtube pages, everytime i navigate to other youtube's pages, it get stuck, then i reload it, then its half working, some still stuck forever. In google images, everytime i click a result from the searches (i click the first cat/fourth image), it just showing blank (fifth image) I already try to turn on/off extensions, remove them, clear cache, clear cookies, try the private window, it still doesn't resolve the problem I check my internet connection, it working just fine, i can access other websites without problem, i try to open in other browser (edge), it work just fine too, it just happen on my firefox and specifically only on youtube and google images i try use vpn/dns stuff, still doesn't work, i have no idea what is wrong with my browser, so please someone help me fix this problem since firefox is my default (and favorite) browser and i also rely on the two websites for working daily, thank you tldr; firefox take forever to load youtube & google images, please help me i have no idea what to do
Attached screenshots

All Replies (7)

more options

As a test... Download a different version of Firefox (ESR, Beta, Dev, or Nightly) and see if you have the same issue. Make sure to install to a different directory than your current install.

https://www.mozilla.org/en-US/firefox/all/#product-desktop-release

Modified by jonzn4SUSE

more options

I forgot to ask... What security software are you running? Do you have the same issue under a different Windows account?

more options

tried the esr, i cant even open it now...

i dont use any security software

more options

Try the refresh option, but if you have bookmarks I would export them just to be safe. https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings

more options

This could be a problem with the TLS 1.3 Early Data feature also known as Zero Round Trip Time Resumption (0rtt). You can try to set security.tls.enable_0rtt_data = false on the about:config page to disable this feature until this is fixed by Google or Mozilla to see if that helps.

See also:

more options

tried everything above, still the same

more options

Did you restart Firefox after toggling security.tls.enable_0rtt_data ?

You can check the Network Monitor to see if content is blocked or otherwise fails to load and also check the Timings tab.

If necessary use "Ctrl+F5" or "Ctrl+Shift+R" (Mac: Command+Shift+R) to reload the page and bypass the cache to generate a fresh log.

You can check the Web Console (Tools -> Web Developer) for messages about blocked content.