ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Opening new tabs switches to them immediately despite the settings being the opposite.

more options

I don't want tabs i open through middle click to be focused immediately. I checked my settings and they aren't supposed to be doing that based on what I see. How do I get this to stop?

I don't want tabs i open through middle click to be focused immediately. I checked my settings and they aren't supposed to be doing that based on what I see. How do I get this to stop?
Attached screenshots

الحل المُختار

It could be that middle-clicking the link is triggered a script that opens a popup window, which Firefox then diverts to a new tab. If you want diverted tabs to open in the background, there is a hidden setting for that. Let me describe a family of related settings:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste inback and pause while the list is filtered

Firefox should list out several preferences for different scenarios. Here's what they do:

(A) browser.search.context.loadInBackground => this refers to when you select text in a page and choose the "Search [default engine] for [selected text] item"

(B) browser.tabs.loadBookmarksInBackground => this refers to when you click a bookmark

(C) browser.tabs.loadDivertedInBackground => this refers to links that target a new window (via attribute or script) that Firefox diverts to a new tab instead **try switching this one to true by double-clicking it**

(D) browser.tabs.loadInBackground => this is the one that has a checkbox on the Settings page

(E) services.sync.prefs.sync.browser.tabs.loadInBackground => ignore this, it controls whether to Sync #D between your different installations of Firefox

Read this answer in context 👍 1

All Replies (1)

more options

الحل المُختار

It could be that middle-clicking the link is triggered a script that opens a popup window, which Firefox then diverts to a new tab. If you want diverted tabs to open in the background, there is a hidden setting for that. Let me describe a family of related settings:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste inback and pause while the list is filtered

Firefox should list out several preferences for different scenarios. Here's what they do:

(A) browser.search.context.loadInBackground => this refers to when you select text in a page and choose the "Search [default engine] for [selected text] item"

(B) browser.tabs.loadBookmarksInBackground => this refers to when you click a bookmark

(C) browser.tabs.loadDivertedInBackground => this refers to links that target a new window (via attribute or script) that Firefox diverts to a new tab instead **try switching this one to true by double-clicking it**

(D) browser.tabs.loadInBackground => this is the one that has a checkbox on the Settings page

(E) services.sync.prefs.sync.browser.tabs.loadInBackground => ignore this, it controls whether to Sync #D between your different installations of Firefox

Helpful?

اطرح سؤالا

عليك الولوج إلى حسابك للردّ على المشاركات. من فضلك اطرح سؤالًا جديدًا لو لم يكن لديك حساب بعد.