ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Custom theme not loading (always reverting to the default). This is my quick solution.

  • 1 (رد واحد)
  • 1 has this problem
  • 2 views
  • آخر ردّ كتبه Dropa

more options

My custom theme was reverting back to the default every time I started Firefox. Going into my theme and disabling and re-enabling it worked, but having to do that every time was annoying. Googling the problem came up with many links to Mozilla support and only said that that it was likely a setting in the "prefs.js" file or a corrupted "extensions.json" file. Unfortunately, no one else was pointing me to what parameter in the prefs.js file I needed to search for. So I had to find it myself. So I made a backup of the file for safety, fired up my Edit Pad Lite text editor, and opened the prefs.js file. Yikes, lots of values. So I carefully searched for the word "theme". I kept pressing F3 to continue searching for the next occurrence of the word "theme" (without the quotes of course). I finally found these 2 lines:

user_pref("lightweightThemes.persisted.footerURL", true); user_pref("lightweightThemes.persisted.headerURL", false);

Hmm. The lightweight theme header was false. Could it be that simple to change it to true? So I made sure I had shut down Firefox as Mozilla states that the prefs.js file is overwritten by Firefox upon exiting, changed the value to "true", saved the file, and restarted Firefox. Viola, my theme stayed on. I selected other themes, exited and restarted Firefox, and that theme was still there and not reset to the default. My problem was solved. I don't know how that value got set to "false" (and don't care), but now that it's set to "true" my theme is working every time I use Firefox. I'm surprised that no one else had found and posted this simple solution.

My custom theme was reverting back to the default every time I started Firefox. Going into my theme and disabling and re-enabling it worked, but having to do that every time was annoying. Googling the problem came up with many links to Mozilla support and only said that that it was likely a setting in the "prefs.js" file or a corrupted "extensions.json" file. Unfortunately, no one else was pointing me to what parameter in the prefs.js file I needed to search for. So I had to find it myself. So I made a backup of the file for safety, fired up my Edit Pad Lite text editor, and opened the prefs.js file. Yikes, lots of values. So I carefully searched for the word "theme". I kept pressing F3 to continue searching for the next occurrence of the word "theme" (without the quotes of course). I finally found these 2 lines: user_pref("lightweightThemes.persisted.footerURL", true); user_pref("lightweightThemes.persisted.headerURL", false); Hmm. The lightweight theme header was false. Could it be that simple to change it to true? So I made sure I had shut down Firefox as Mozilla states that the prefs.js file is overwritten by Firefox upon exiting, changed the value to "true", saved the file, and restarted Firefox. Viola, my theme stayed on. I selected other themes, exited and restarted Firefox, and that theme was still there and not reset to the default. My problem was solved. I don't know how that value got set to "false" (and don't care), but now that it's set to "true" my theme is working every time I use Firefox. I'm surprised that no one else had found and posted this simple solution.

Modified by markb6

All Replies (1)

more options

Where did you get the custom theme from and what instructions did they include to load it?