ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Bookmark toolbar font size

  • 17 ردًا
  • 1 has this problem
  • 54 views
  • آخر ردّ كتبه mmtodd

more options

‘Beautiful new 27in iMAC with Retina Display. But the fonts in the toolbar as now so small as to be unreadble (old guy eyes). But I can't find anwhere in Preferences or otherwise to enlarge them.’ Easy to enlarge the text on the webpages themselves - but not in the toolbar. HELP

‘Beautiful new 27in iMAC with Retina Display. But the fonts in the toolbar as now so small as to be unreadble (old guy eyes). But I can't find anwhere in Preferences or otherwise to enlarge them.’ Easy to enlarge the text on the webpages themselves - but not in the toolbar. HELP

All Replies (17)

more options

Set your DPI in settings Firefox about:config - layout.css.dpi

P.S. For example, I have : layout.css.dpi 89

WARNING: Changing preferences through this interface not officially supported Hidden settings edited using the about:config tool are explicitly not supported, which means that Mozilla makes no guarantees they will be supported in the future, or that Mozilla will fix them if they break. Mozilla does not test these preferences, and will not in the future. That includes security and performance testing which these preferences may affect.

[Warning added by moderator]

Modified by Chris Ilias

Helpful?

more options

Sorry, lost me. I can get into Settings but don't see anyplace to enter this information.

Helpful?

more options

mmtodd said

Sorry, lost me. I can get into Settings but don't see anyplace to enter this information.

https://imgur.com/6xi3UW1

Helpful?

more options

image

Helpful?

more options

In the address bar enter the address about:config and go, then in the search bar enter layout.css.dpi and change the number -1 to your dpi. Press enter.

P.S. Instead of the number -1, try putting different numbers from 90 to 100 The number -1 by default means standard dpi - equal to 96

WARNING: Changing preferences through this interface not officially supported Hidden settings edited using the about:config tool are explicitly not supported, which means that Mozilla makes no guarantees they will be supported in the future, or that Mozilla will fix them if they break. Mozilla does not test these preferences, and will not in the future. That includes security and performance testing which these preferences may affect.

[Warning added by moderator]

Modified by Chris Ilias

Helpful?

more options

Helpful?

more options

Helpful?

more options

This is what see - can't find anywhere to change DPI. Sorry

Helpful?

more options

You can set layout.css.devPixelsPerPx to 1.0 (default is -1) on the about:config page.

WARNING: Changing preferences through this interface not officially supported Hidden settings edited using the about:config tool are explicitly not supported, which means that Mozilla makes no guarantees they will be supported in the future, or that Mozilla will fix them if they break. Mozilla does not test these preferences, and will not in the future. That includes security and performance testing which these preferences may affect.

[Warning added by moderator]

Adjust its value in 0.1 or 0.05 steps (1.1 to enlarge or 0.9 to reduce) until icons or text looks right. Make sure not to use values too large or too small.

  • modifying layout.css.devPixelsPerPx affects user interface and webpages (global zoom)

Firefox has a Zoom section in Settings to set the default zoom level for webpages.

  • Settings -> General -> Language and Appearance -> Zoom

You can open the about:config page via the location/address bar. Clear cookies the button to "Accept the Risk and Continue".

Modified by Chris Ilias

Helpful?

more options

Seriously screwed. Was able to get to the layout page. Default was -1. I made what I thought was a small change (per directions) and now I have the attached. Can't even get to a readable browser - no menu bars big enough to enter anything into. Tried downloading new version - same thing. HELP.

Helpful?

more options

mmtodd said

Seriously screwed. Was able to get to the layout page. Default was -1. I made what I thought was a small change (per directions) and now I have the attached. Can't even get to a readable browser - no menu bars big enough to enter anything into. Tried downloading new version - same thing. HELP.

After quitting Firefox, try starting it in its Safe/Troubleshoot Mode. Hold down the option/alt key when starting Firefox. (On Windows, hold down the Shift key instead of the option/alt key.) A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

Does Firefox use the custom DPI or ignore that and use the default DPI?

If text is readable: You can go back to about:config and set the preference to a value no lower than 2.5 (since presumably it's a Retina monitor and you need to double the values used on other kinds of monitors).

If text is not readable:

We're going to do a partial reset of custom settings to get back to normal and then consider data recovery options afterwards.

Open the Troubleshooting Information page:

Help > More Troubleshooting Information

Try to zoom the page as much as possible (hold down Command and tap the + key numerous times)

Open Find in page using Command+F

Type or paste profile folder and press Return to search for it. The highlighted result should be about halfway down the first table. On that same row, just to the right, should be a button to "Show in Finder" or Open Folder". Click that button to launch a Finder window.

If Finder highlights an icon with a semi-random name like a1b2c3d4.default, double-click it to display the contents of that profile folder.

Leaving that window open, switch back to Firefox and Quit (Firefox > Quit).

Pause while Firefox finishes its cleanup, then:

Hide or Edit prefs.js

Edit option

If you are handy with text editors, you could try removing the problem setting from the prefs.js file, or editing it by hand. That line looks like this, with the value you entered toward the end of the line:

user_pref("layout.css.devPixelsPerPx", "1.25");

Deleting that line will remove the customization. You also could edit it to a larger number, such as

user_pref("layout.css.devPixelsPerPx", "2.5");

Important: Do not let your text editor upgrade the format of the file or it will be corrupted, it must remain a plain text file.

Hide option

Otherwise, you can hide the prefs.js file from Firefox to reset custom settings in the browser.

Either rename the prefs.js file (for example prefsOLD.js) or drag it out of this folder (for example to the desktop). You also could delete it, but some settings stored in this file might be worth keeping for reference.

Start Firefox back up again and it should return to default settings. So far so good?

Helpful?

more options

Sorry, no luck. I tried the Alt key start - but even after hitting command-+ dozens of times, the biggest image i can see is attached. Too small to identify anything. Is there some way to just trash Firefox and all of its "behind the scenes" files (library, prefs etc) and start over??

Helpful?

more options

You need to locate the prefs.js in the profile folder and either edit this file and remove the user_pref("layout.css.devPixelsPerPx", "xx") or rename prefs.js to prefsOLD.js to reset al current prefs.

Location used for the main profile that keeps your personal data (Root Directory on about:profiles).

  • ~/Library/Application Support/Firefox/Profiles/<profile>

In Mac OS X v10.7 and later, the "~/Library" folder in the Home directory is a hidden folder.

Helpful?

more options

I gave up. I just trashed Firefox and dumped my profiles - then reloaded everything and resynch my bookmarkes. I'll try the font change later.

Helpful?

more options

Sorry for the late follow-up, I had some calls.

The other option would have been similar: on the Troubleshooting Information page, press tab to highlight the Refresh Firefox button, then press Return to display the confirmation dialog. The red button confirms.

Anyway, now that you have a new profile, you may want to back up the prefs.js file somewhere before making the font change the next time.

Helpful?

more options

Hi Todd, I'm on mac, so I should be able to help. First, please do not use the preference others are advising you to change. It is not supported. The cause may be in your system preference, but first I'd like to see what you're experiencing. The toolbar font size in the previous screenshot you shared looks normal. Would you mind sending us a screenshot of the issue?

Helpful?

more options

See attached. In this shot, things "look good" but on my 27in Retina display, they lettering is so small as to be very hard for me to see. You can see how I've zoomed up the text below (cmd+).

Helpful?

اطرح سؤالا

عليك الولوج إلى حسابك للردّ على المشاركات. من فضلك اطرح سؤالًا جديدًا لو لم يكن لديك حساب بعد.