ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox Stops Loading New Websites after Background Update

  • 7 ردود
  • 1 has this problem
  • 58 views
  • آخر ردّ كتبه nick156

more options

I usually have Firefox open for 8 hours a day (open Firefox in the morning and close it in the afternoon). About once a week I'll notice that at some point during the day Firefox will just stop loading new websites. Existing sites will continue to function, and requests to those existing domains work. But new sites, that I didn't already have open, won't load at all; the tab will just sit there, thinking indefinitely (no errors).

When it does this I will try microsoft.com or google.com to check and make sure it isn't just the site, but those won't load either. I'll try it with a Private Window as well to the same effect (private window has no extensions enabled). Chrome/Edge still work fine during this. In order to get Firefox working again, I have to close Firefox and then usually force quit the process instances (or wait a long time for it to reopen on its own). Once reopened everything is back to normal and all sites load as normal.

I think this happens when Firefox loads a new update in the background. I've noticed on more than one occasion this behavior has coincided with a new Firefox version. In fact it just did it again (prompting this post) and when I got Firefox back open again it had a new update tab displayed. So I'm fairly sure it is the background updates causing this.

This behavior has been happening for a very long time. At least 6 months. Across many Firefox updates.

I have a separate Firefox profile that I load using a separate shortcut (with the -P property). When this behavior happens it often impacts both instances of Firefox. Not sure if this bug is related to having multiple profiles or not.

Windows 10 64-bit

I usually have Firefox open for 8 hours a day (open Firefox in the morning and close it in the afternoon). About once a week I'll notice that at some point during the day Firefox will just stop loading new websites. Existing sites will continue to function, and requests to those existing domains work. But new sites, that I didn't already have open, won't load at all; the tab will just sit there, thinking indefinitely (no errors). When it does this I will try microsoft.com or google.com to check and make sure it isn't just the site, but those won't load either. I'll try it with a Private Window as well to the same effect (private window has no extensions enabled). Chrome/Edge still work fine during this. In order to get Firefox working again, I have to close Firefox and then usually force quit the process instances (or wait a long time for it to reopen on its own). Once reopened everything is back to normal and all sites load as normal. I think this happens when Firefox loads a new update in the background. I've noticed on more than one occasion this behavior has coincided with a new Firefox version. In fact it just did it again (prompting this post) and when I got Firefox back open again it had a new update tab displayed. So I'm fairly sure it is the background updates causing this. This behavior has been happening for a very long time. At least 6 months. Across many Firefox updates. I have a separate Firefox profile that I load using a separate shortcut (with the -P property). When this behavior happens it often impacts both instances of Firefox. Not sure if this bug is related to having multiple profiles or not. Windows 10 64-bit

الحل المُختار

My guess is that once Firefox updates, new processes cannot be started because the executable files on disk have been replaced. However, existing processes may continue to work for some time. It's definitely inconvenient because you can't predict when you'll hit the point that requires a restart.

If you haven't by now, you can take control of when your updates install by making a change on the Settings page. On Windows, either:

  • main menu button > Settings
  • (menu bar) Tools > Settings
  • type or paste about:preferences into the address bar and press Enter to load it

In the tiny search box at the top of the page, type update and Firefox should filter to the "Firefox Updates" section. Should look roughly like this:

Select "Check for updates but let you choose to install them". Firefox will write that to a shared settings file and NOT to the preferences file in your current profile. (If you discovered old instructions to make changes in about:config or user.js, those have not been effective in recent years.)

You don't have to worry that you'll miss an update: Firefox will drop down a panel from the main menu button informing you of available updates, and you either can download it immediately or postpone it. You should get daily reminders.

Note for Mac OS users: it should be similar on your OS.

Note for Linux users: if you installed through a package manager, your package manager usually dictates the timing of updates and this setting probably will be ineffective.

Read this answer in context 👍 0

All Replies (7)

more options

Has the problem continued after updating to Firefox 99.0?

Start Firefox using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?

Helpful?

more options

FredMcD said

Has the problem continued after updating to Firefox 99.0? Start Firefox using Troubleshoot(Safe) Mode {web link} A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?

Thank you for the reply.

The problem appears to always happen when a new Firefox update comes out, and Firefox updates in the background. So I won't know until the next Firefox update, but if it's anything like seemingly every update for the last 6 months, the problem will happen again.

Going into Safe Mode appears to require a browser restart, which fixes the problem anyway, so that won't help. The only way that may help is if I know the timing of the next Firefox update, and can make sure I go into Safe Mode just prior to when it will background update, then let it do the update.

Is there a way to know the exact day and time the next Firefox update will come out?

Will Firefox do its normal background update while in Safe Mode?

Helpful?

more options

nick156 said

Is there a way to know the exact day and time the next Firefox update will come out?

See if this link helps; https://wiki.mozilla.org/Release_Management/Calendar

Will Firefox do its normal background update while in Safe Mode?

That I don't know.

Helpful?

more options

Thank you. I'll set a calendar notification for before that next planned release, and troubleshoot with safe mode.

Helpful?

more options

Looks like Firefox had an update today, and I didn't get a chance to try safe mode before it happened. I did collect some more data while it was not working. Hopefully it is somewhat useful.

When it stopped working, it was just the primary profile session I use on my right monitor. The other profile session on my left monitor continued to work. I opened up both "About Firefox" windows to see version stats side-by-side. See picture here:

https://i.leanfoto.com/0hv3pixta.png

I had opened my secondary profile session (on the left monitor) later in the day, so it must have updated to 99.0.1 already while the primary profile session (on the right monitor) wasn't updated. I'm honestly not sure if Firefox keeps separate application versions for each profile, or how that works.

I closed down all Firefox windows, to get it working again, but as usual the Firefox processes took forever to stop (takes about 1-2 minutes on their own, if I don't force quit them). See picture here:

https://i.leanfoto.com/zfwu4qor5.png

(The Mozilla forum's "Add images" feature below is not working well at all, even with 100KB pngs, so that's why I had to use an image host.)

Helpful?

more options

الحل المُختار

My guess is that once Firefox updates, new processes cannot be started because the executable files on disk have been replaced. However, existing processes may continue to work for some time. It's definitely inconvenient because you can't predict when you'll hit the point that requires a restart.

If you haven't by now, you can take control of when your updates install by making a change on the Settings page. On Windows, either:

  • main menu button > Settings
  • (menu bar) Tools > Settings
  • type or paste about:preferences into the address bar and press Enter to load it

In the tiny search box at the top of the page, type update and Firefox should filter to the "Firefox Updates" section. Should look roughly like this:

Select "Check for updates but let you choose to install them". Firefox will write that to a shared settings file and NOT to the preferences file in your current profile. (If you discovered old instructions to make changes in about:config or user.js, those have not been effective in recent years.)

You don't have to worry that you'll miss an update: Firefox will drop down a panel from the main menu button informing you of available updates, and you either can download it immediately or postpone it. You should get daily reminders.

Note for Mac OS users: it should be similar on your OS.

Note for Linux users: if you installed through a package manager, your package manager usually dictates the timing of updates and this setting probably will be ineffective.

Helpful?

more options

Thank you. I think setting it to manual (in both profile instances) will be a good work-around. That way I can at least have it update at the beginning or end of day, and it should stop interrupting the workflow!

Helpful?

اطرح سؤالا

عليك الولوج إلى حسابك للردّ على المشاركات. من فضلك اطرح سؤالًا جديدًا لو لم يكن لديك حساب بعد.