ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

GOOGLEADSERVICES

more options

When I do a search using google, and then click on a choice (one of the first sites listed) my browser tries to go to something called "googleadservices" and it will not load. Just hangs up and gives me a blank page. How do I stop this or remove googleadservices?

When I do a search using google, and then click on a choice (one of the first sites listed) my browser tries to go to something called "googleadservices" and it will not load. Just hangs up and gives me a blank page. How do I stop this or remove googleadservices?

All Replies (5)

more options

That is something websites use to track and send ads in your Browser. You can stop or remove it since it comes from the websites you go to. So unless you have addons or adblocker software those will be always be present.

more options

I don't think you are grasping the problem here. This is something that is actually hijacking my browser. ONLY happens when I search for something using google and then try to go to one of the sites google offers

more options

Hi

Do you have an example of a link that is not opening for you in Firefox?

more options

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content. You can click shield icon for more detail and possibly disable the protection. You can check the Web Console for relevant-looking messages about blocked content.


You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings).

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> [X] Cached Web Content -> Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window
more options

Are you sure those weren't paid ads placed above the "organic" results? Paid ads commonly route through a tracking script. Usually when you click, the switch happens so fast that you don't notice. If you right-click instead, and keep the mouse pointer over the link, you'll see the updated URL in the link hover message at the bottom of the window. (I used Alt+PrintScreen to get this screenshot, which cleared away the right-click context menu.)

If you check where you are having the problem, can you see through a little Ad badge or a colored background that the problem is with paid ads?

Assuming so, you might wonder why Firefox would stop at that URL. One possible reason would be an ad blocker, but another would be the redirect block. Please make sure the redirect block is turned off as this can bite you with mysterious blank pages on a lot of sites:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future. Since we are restoring the default behavior, I feel comfortable mentioning it.

(2) In the search box in the page, type or paste accessibility.blockautorefresh and pause while the list is filtered

(3) If the preference has a value of true, double-click it to restore the default value of false