ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Windows 10 taskbar not appearing in Firefox windows

  • 2 (ردّان اثنان)
  • 1 has this problem
  • 229 views
  • آخر ردّ كتبه luketaylorLT

more options

I'm running Win10. When in FF browser the taskbar, which I have set to appear at the bottom of my screen, does not appear. I normally use "auto hide taskbar" setting in windows, and tried to turn this off to see if the taskbar would again appear while using FF. It did not. So, the taskbar seems lost when in FF. This has happened before, appears it is an intermittent issue. My windows10 is fully up to date as is my FF browser.

I'm running Win10. When in FF browser the taskbar, which I have set to appear at the bottom of my screen, does not appear. I normally use "auto hide taskbar" setting in windows, and tried to turn this off to see if the taskbar would again appear while using FF. It did not. So, the taskbar seems lost when in FF. This has happened before, appears it is an intermittent issue. My windows10 is fully up to date as is my FF browser.

الحل المُختار

Firefox has a full screen setting that hides the Taskbar even when Autohide is not enabled. Could you check whether that is the problem? The F11 key switches full screen mode on/off. (This is different from the kind of full screen web pages can invoke. Usually you click a button in the page to go to full screen, and tap the Esc key to exit.)

If full screen is not the problem, hmm. Sometimes the settings file that stores window dimensions becomes corrupted with nonsensical values. You can rename the file and have Firefox rebuild it. Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > Help > More Troubleshooting Information
  • (menu bar) Help > More Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, on the Profile Folder row, click the "Open Folder" button. This should launch a new window listing various files and folders in Windows File Explorer. (For example, there should be a folder named bookmarkbackups at or near the top of the list.)

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > Exit
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then:

Right-click xulstore.json then Rename to something like xulstoreOLD.json

Start Firefox back up again. Do windows display normally again?

That mini-reset may hide the bookmarks toolbar and/or menu bar. You can use one of these methods to show the toolbar list and select the desired bars there:

  • right-click (on Mac Ctrl+click) a blank spot on the tab bar (or the "+" button)
  • (menu bar) View > Toolbars
    On Windows, tap the Alt key or F10 key to activate the menu bar temporarily.
  • in Customize mode > Toolbars button (see: Customize Firefox controls, buttons and toolbars)

To turn on the Menu Bar, click it on the list. There are multiple options for the Bookmarks Toolbar.

Read this answer in context 👍 0

All Replies (2)

more options

الحل المُختار

Firefox has a full screen setting that hides the Taskbar even when Autohide is not enabled. Could you check whether that is the problem? The F11 key switches full screen mode on/off. (This is different from the kind of full screen web pages can invoke. Usually you click a button in the page to go to full screen, and tap the Esc key to exit.)

If full screen is not the problem, hmm. Sometimes the settings file that stores window dimensions becomes corrupted with nonsensical values. You can rename the file and have Firefox rebuild it. Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > Help > More Troubleshooting Information
  • (menu bar) Help > More Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, on the Profile Folder row, click the "Open Folder" button. This should launch a new window listing various files and folders in Windows File Explorer. (For example, there should be a folder named bookmarkbackups at or near the top of the list.)

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > Exit
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then:

Right-click xulstore.json then Rename to something like xulstoreOLD.json

Start Firefox back up again. Do windows display normally again?

That mini-reset may hide the bookmarks toolbar and/or menu bar. You can use one of these methods to show the toolbar list and select the desired bars there:

  • right-click (on Mac Ctrl+click) a blank spot on the tab bar (or the "+" button)
  • (menu bar) View > Toolbars
    On Windows, tap the Alt key or F10 key to activate the menu bar temporarily.
  • in Customize mode > Toolbars button (see: Customize Firefox controls, buttons and toolbars)

To turn on the Menu Bar, click it on the list. There are multiple options for the Bookmarks Toolbar.

more options

Thank you! Some messing around with FLock/F11 fixed the issue, although FF exhibited some strange behavior as I toggled between the full screen on and off. With full screen on all my tabs across the top were invisible as was the task bar, where before the tabs were visible but the task bar wasn't. When toggled to full screen off both the tabs and the task bar reappeared. So, I seemed to have been stuck somewhere in the twilight zone in between settings. Also, auto-hide is now working again, so that's good!