ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

App will only open as a background instance whenever I try to run it.

  • 4 ردود
  • 1 has this problem
  • 37 views
  • آخر ردّ كتبه James

more options

So I got on my computer today, and I tried to open Firefox, but it wouldn't open, I would get a loading icon on my cursor and then nothing. So I restarted my computer, same issue. Reinstalled Firefox, same issue. I then reinstalled after having deleted the %appdata% folder for Mozilla, but that also changed nothing. So I looked in Task Manager, and it would just open instances of Firefox as a background app no matter how many times I clicked. I've also tried using other browsers with no success. (Also, I'm runnning Windows 10, 64-Bit version, and had not installed any programs recently before Firefox stopped working.) I would greatly appreciate if I could get some assistance with this because I prefer Firefox much more than Microsoft Edge which is the only browser I'm able to use right now.

So I got on my computer today, and I tried to open Firefox, but it wouldn't open, I would get a loading icon on my cursor and then nothing. So I restarted my computer, same issue. Reinstalled Firefox, same issue. I then reinstalled after having deleted the %appdata% folder for Mozilla, but that also changed nothing. So I looked in Task Manager, and it would just open instances of Firefox as a background app no matter how many times I clicked. I've also tried using other browsers with no success. (Also, I'm runnning Windows 10, 64-Bit version, and had not installed any programs recently before Firefox stopped working.) I would greatly appreciate if I could get some assistance with this because I prefer Firefox much more than Microsoft Edge which is the only browser I'm able to use right now.

الحل المُختار

If you run Webroot

People are working with Webroot to issue an update.

Until then, a user posted that another workaround would be to run Firefox 97 in backwards compatibility mode. I haven't tested this myself, but here is how you would set that up:

(1) Open the Properties dialog for your Firefox shortcut. Either:

  • right-click a Desktop shortcut, then click Properties
  • right-click a pinned Taskbar icon, then right-click the Firefox (or Mozilla Firefox) item, then click Properties

(2) Switch to the Compatibility tab

(3) Check the box for "Run this program in compatibility mode for"

(4) If the selector for that option is not set on Windows 8, switch it to Windows 8

As a result of this change, you may notice that some Windows 10-specific features and styling are disabled. However, I am not aware of any major changes. If you experiment with this, let us know your experience.

Read this answer in context 👍 0

All Replies (4)

more options

Soren said

I've also tried using other browsers with no success . . . Microsoft Edge which is the only browser I'm able to use right now.

Please explain, no web browser will open?

Some problems occur when your Internet security program was set to trust the previous version of Firefox, but no longer recognizes your updated version as trusted. Now how to fix the problem: To allow Firefox to connect to the Internet again;

  • Make sure your Internet security software is up-to-date (i.e. you are running the latest version).
  • Remove Firefox from your program's list of trusted or recognized programs. For detailed instructions, see

Configure firewalls so that Firefox can access the Internet. {web link}


Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there?

Starting Any Computer In Safe Mode (web link) Free Online Encyclopedia

https://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/

https://www.digitalcitizen.life/4-ways-boot-safe-mode-windows-10/ +++++++++++++++++++++++++++++++++++++++++++++++ If the problem goes away with the computer in Safe Mode, the problem is with one of the other programs on the system.

As a test, disable your protection programs.

more options

Could this be relevant? A couple of other users identified Webroot (security software) as blocking 64-bit Firefox 97 -- released today -- from running properly:

If you are still running an earlier release of Firefox, this would not be your issue.

more options

الحل المُختار

If you run Webroot

People are working with Webroot to issue an update.

Until then, a user posted that another workaround would be to run Firefox 97 in backwards compatibility mode. I haven't tested this myself, but here is how you would set that up:

(1) Open the Properties dialog for your Firefox shortcut. Either:

  • right-click a Desktop shortcut, then click Properties
  • right-click a pinned Taskbar icon, then right-click the Firefox (or Mozilla Firefox) item, then click Properties

(2) Switch to the Compatibility tab

(3) Check the box for "Run this program in compatibility mode for"

(4) If the selector for that option is not set on Windows 8, switch it to Windows 8

As a result of this change, you may notice that some Windows 10-specific features and styling are disabled. However, I am not aware of any major changes. If you experiment with this, let us know your experience.

more options

https://www.mozilla.org/firefox/97.0.1/releasenotes/

Fixed Works around problems with WebRoot SecureAnywhere antivirus rendering Firefox unusable in some situations