ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Webroot blocking Firefox 97.0 (64-bit) functionality

  • 11 ردًا
  • 14 have this problem
  • 1566 views
  • آخر ردّ كتبه James

more options

Firefox updated to 97.0 (64-bit) this morning for me and immediately ceased functioning. It could not even load about:addons or about:settings. Other browsers worked fine, and by processes of elimination I found it to be Webroot that was causing the dysfunction. I've already opened a support ticket with Webroot, but I wanted to make Mozilla aware of this conflict and to ask if there is anything that I can do to remedy this besides completely disabling my anti-virus/spyware to use Firefox?

Firefox updated to 97.0 (64-bit) this morning for me and immediately ceased functioning. It could not even load about:addons or about:settings. Other browsers worked fine, and by processes of elimination I found it to be Webroot that was causing the dysfunction. I've already opened a support ticket with Webroot, but I wanted to make Mozilla aware of this conflict and to ask if there is anything that I can do to remedy this besides completely disabling my anti-virus/spyware to use Firefox?

All Replies (11)

more options

Thank you for the report. Another user posted about it on Webroot's forum tonight, so hopefully they'll come up with a quick fix:

https://community.webroot.com/webroot-secureanywhere-antivirus-12/webroot-blocking-firefox-97-0-64-bit-350229

more options

People are working with Webroot to issue an update.

Until then, a user posted that another workaround would be to run Firefox 97 in backwards compatibility mode. I haven't tested this myself, but here is how you would set that up:

(1) Open the Properties dialog for your Firefox shortcut. Either:

  • right-click a Desktop shortcut, then click Properties
  • right-click a pinned Taskbar icon, then right-click the Firefox (or Mozilla Firefox) item, then click Properties

(2) Switch to the Compatibility tab

(3) Check the box for "Run this program in compatibility mode for"

(4) If the selector for that option is not set on Windows 8, switch it to Windows 8

As a result of this change, you may notice that some Windows 10-specific features and styling are disabled. However, I am not aware of any major changes. If you experiment with this, let us know your experience.

more options

Wow, thanks! I even went through the trouble of upgrading to Windows 11 to try and fix this! I do have Webroot installed, so that is likely the issue. I'm the only one in my office using Firefox, which explains why no one else is complaining today!

Switching to Windows 8 compatibilty solved the problem! It is running fast and smooth at the moment. Very strange issue....

more options

This worked for me also. Hope to get the update when we can go back to normal. Thanks

more options

I have Webroot as well on all my machines. I tried wiping out Firefox 97 and reloading everything from scratch (I even wiped out the profiles) and I still could not type in some URL's and access them. I also tried in SAFEMODE and that failed as well, which should have eliminated Webroot. I also removed all Addins to run as plain as I could and it failed.

I could try to load simple URL's like Google and that would fail sometimes. Some other URL's like CNN would work for a while then stop suddenly.

I finally downloaded Firefox Version 95 and installed it while blocking updates to the latest version. Everything works fine again. Normally I haven't found Webroot to affect Firefox as I've been using it for 10+ years. Firefox tries to install Webroot extension during installation of Version 97. I tried turning it off as part of my earlier testing and that didn't fix the problem at that time. Just the fact that Webroot is still running on the machine may still be a problem even with it removed from direct interaction with Firefox 97.

I have another machine that is on the same Windows 10 release and is running Webroot and it is working fine.

My machine desktop machine that is having trouble is using AMD 3950X CPU while the other desktop machine that is working properly is on I7-Intel. Most other software is the same on both machines.

more options

mcginnis13 said

I also tried in SAFEMODE and that failed as well, which should have eliminated Webroot.

The problem actually involves a completely different component of Webroot, not the add-on. Webroot injects code into browser processes and due to some change in the combination of Webroot, Windows 10-11, and 64-bit Firefox 97, this prevents Firefox from running normally.

Oddly, a few users reported that uninstalling and reinstalling Webroot (the Windows application, not the add-on) resolved it for them. I don't understand why that would work if it's the identical version, but maybe it reads the landscape a bit differently at install time???

more options

Same issue here on multiple computers on our network. The temporary fix above of running it in compatibility mode on Windows 8 works for all affected computers.

more options

Looking at https://bugzilla.mozilla.org/show_bug.cgi?id=1752466 I see they are still working on it. Thanks for the windows 8 compatibility work around. Now how will we know when they have fixed it and we should revert the windows compatibility to 10 ?

Modified by djrmich

more options

djrmich said

Looking at https://bugzilla.mozilla.org/show_bug.cgi?id=1752466 I see they are still working on it. Thanks for the windows 8 compatibility work around. Now how will we know when they have fixed it and we should revert the windows compatibility to 10 ?

When a Firefox update comes out, such as maybe 97.0.1, it would be listed in the Release Notes. However, I don't know the expected timing, it might not be until next month's release of Firefox 98.

more options

Here's a labor-intensive permanent workaround that works for us:

- Uninstall Firefox
- Uninstall Webroot
- Reboot
- Reinstall Firefox
- Reinstall Webroot
- Now everything is happy
- Doesn't care if the add-on is installed in FF or if html3 is enabled/disabled
 Unfortunately we have some systems that won't show up in webroot console, and won't even let admins uninstall without the console.  For those we have to reboot into safe mode, then proceed.

Modified by mcrawf

more options

https://www.mozilla.org/firefox/97.0.1/releasenotes/

Fixed Works around problems with WebRoot SecureAnywhere antivirus rendering Firefox unusable in some situations