ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Google docs font rendering

  • 4 ردود
  • 1 has this problem
  • 9 views
  • آخر ردّ كتبه FredMcD

more options

Hello, For quite some time, Firefox seems to have a problem with Google docs. 1) The text on Google docs is blurred. I have attached screenshots that compare its appearance on Firefox and Edge. 2) Some functions of Google docs do not work. I can't use the shortcut Ctrl+Alt+M to insert a comment, but on Edge, this works fine.

I am using Windows 10, Firefox 96.0.3. I have tried restarting Firefox in Troubleshooting mode, but it made no changes to these issues.

What could be the reason for this?

Hello, For quite some time, Firefox seems to have a problem with Google docs. 1) The text on Google docs is blurred. I have attached screenshots that compare its appearance on Firefox and Edge. 2) Some functions of Google docs do not work. I can't use the shortcut Ctrl+Alt+M to insert a comment, but on Edge, this works fine. I am using Windows 10, Firefox 96.0.3. I have tried restarting Firefox in Troubleshooting mode, but it made no changes to these issues. What could be the reason for this?
Attached screenshots

All Replies (4)

more options

[v56+] Type about:preferences#general<enter> in the address box. Under fonts and colors, press the Advanced button. Scroll to the bottom, turn on Allow Web Sites To Choose Their Own.

Make sure you haven't enabled a High Contrast theme in the OS settings.

  • We have seen reports that this can be caused by a problem with fonts like Roboto or Helvetica that

you have installed locally and that might be corrupted or are missing some variants. Also, make sure you allow pages to choose their own fonts and that you do not block remote (downloadable) fonts.

  • If you use uBlock Origin make sure not to "block remote fonts".
more options

Make sure you are not blocking content.

https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop also see https://blog.mozilla.org/security/2021/03/23/introducing-smartblock/

https://support.mozilla.org/en-US/kb/smartblock-enhanced-tracking-protection


Diagnose Firefox issues using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

more options

Thank you for the response!

I don't have any custom fonts installed, adblock does not block remote fonts, and the option "Allow Web Sites To Choose Their Own" has been turned on.

The problem is present when starting Firefox on Troubleshoot mode.

However, I just created a new profile and started Firefox from that. That solved the issue, so apparently this is caused by something that is in my profile. Since the Troubleshoot mode disables addons, this must mean that addons are not the reason for this behavior.

I'll continue investigating this, so that I can continue using my current profile.

more options

That was very good work. Well Done. Please flag your last post as Solved Problem as this can help others with similar problems. Go to that post and click the 'Solved' button to its right.