ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Extensions not working

  • 10 ردود
  • 1 has this problem
  • 57 views
  • آخر ردّ كتبه FredMcD

more options

Hi Mozilla Community,

As of a couple of days ago, I've had trouble with my Firefox Extensions. The most apparent one being ads appearing on the sites I browse (I have the Adblock extension installed and active). The extension that reveals the "dislike" ratio on Youtube only works if I disable and then enable the extension, for each video I watch. My entire extensions toolbar seems faulty as well.

I've attached images to illustrate: - Rakuten just appears as a blank box upon clicking it - Video downloader extensions just appear as a white line (doesn't open at all) - Bitwarden (password manager) says "not available in private mode", even though I'm not using a private window

Any help would be greatly appreciated. Thanks, Matt

Hi Mozilla Community, As of a couple of days ago, I've had trouble with my Firefox Extensions. The most apparent one being ads appearing on the sites I browse (I have the Adblock extension installed and active). The extension that reveals the "dislike" ratio on Youtube only works if I disable and then enable the extension, for each video I watch. My entire extensions toolbar seems faulty as well. I've attached images to illustrate: - Rakuten just appears as a blank box upon clicking it - Video downloader extensions just appear as a white line (doesn't open at all) - Bitwarden (password manager) says "not available in private mode", even though I'm not using a private window Any help would be greatly appreciated. Thanks, Matt
Attached screenshots

الحل المُختار

I figured out Ant Video Downloader lead to those issues, and a memory problem that affected Firefox's RAM usage drastically.

Upon removing the extension, all has been resolved. Thanks for the responses everyone!

Read this answer in context 👍 0

All Replies (10)

more options

Let's start with; It’s possible that there is a problem with the file(s) that store the extensions registry.

Type about:support in the address box and press enter.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder

Linux: Under the page logo on the left side, you will see Application Basics. Under this find Profile Directory. To its right press the button Open Directory.

Delete all extensions* files and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

After, restart Firefox.

See "Corrupt extension files"

+++++++++++++++++++++++++++ You may have to approve the updating once again.

more options

Thanks for getting back to me, FredMcD. I tried those steps and restarted Firefox, but unfortunately those issues still persist.

more options
more options

Yeah, unfortunately the problem is still there after a reboot.

By chance, I stumbled onto this thread: https://support.mozilla.org/en-US/questions/1363395

I think the issues may be linked somehow.

more options

I called for more help.

more options

Thanks, Fred.

more options

You can try "Clear the startup cache..." via the "Help -> More Troubleshooting Information" (about:support) page.

more options

Thanks for your response, cor-el. I tried clearing the startup cache and restarting, but still nothing.

more options

الحل المُختار

I figured out Ant Video Downloader lead to those issues, and a memory problem that affected Firefox's RAM usage drastically.

Upon removing the extension, all has been resolved. Thanks for the responses everyone!

more options

That was very good work. Well Done.