ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Audio stops working on Firefox 95.0.2 after a few days

  • 4 ردود
  • 1 has this problem
  • 126 views
  • آخر ردّ كتبه 365nice

more options

I've been teaching my young daughter how to use a computer, and we chose firefox as a browser she can use to do some things online - in particular she's been doing Math lessons using https://www.themathsfactor.com

After the past few weeks I've noticed that sound from that site no longer seems to work after 1 or 2 days. Embedded videos work, but sound where the site has a character that tells her what to do - stops working. If I restart the browser it starts working again - however refreshing the page does not. This is something recent, as older versions of firefox did not seem to do this. I'm wondering if there is some change/memory leak that might cause this?

I've been teaching my young daughter how to use a computer, and we chose firefox as a browser she can use to do some things online - in particular she's been doing Math lessons using https://www.themathsfactor.com After the past few weeks I've noticed that sound from that site no longer seems to work after 1 or 2 days. Embedded videos work, but sound where the site has a character that tells her what to do - stops working. If I restart the browser it starts working again - however refreshing the page does not. This is something recent, as older versions of firefox did not seem to do this. I'm wondering if there is some change/memory leak that might cause this?

الحل المُختار

Hmm its now days and working fine - so perhaps it was something OS related. I think we can close this, and I will report it again if it crops up.

Read this answer in context 👍 0

All Replies (4)

more options

Is it only on that one website? What about other websites?

About how long before the problem shows up?


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem,

Start Firefox using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?

While you are in Troubleshoot(Safe) mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

more options

As I restarted my Firefox to confirm it started working again, I will need respond in a few days . I’ll find some other site with similar sound on a webpage and confirm it works (in fact several may be helpful , as I can leave another one open and open the other fresh ones when it re-occurs).

Opening the browser in safe mode won’t help, as restarting the browser does cure the problem (unless I run in safe mode for several days - which is a possibility, although the only plugin I am using is 1Password which would seem a strange k d to cause this issue).

As mentioned, it’s only recently I’ve noticed this happening - in Nov we were doing a daily exercise with the browser staying open a number of days without issue.

Anyway, I will report back with more info or a solution if it’s not a k own thing.

more options

3 days later and since a restart it hasn't yet lost its sound capabilities. This has happened to me 2x before - but I'll keep monitoring as possibly a newer firefox has changed something and I didn't realise. I'll report back in a few more days.

more options

الحل المُختار

Hmm its now days and working fine - so perhaps it was something OS related. I think we can close this, and I will report it again if it crops up.