On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

My tab delete X turns into a 1 pixel point

more options

I had a similar problem last year when an auto update came through. After several suggestions didn't help I opted to reinstall a previous version and upgrade that. Now it's back again with the v94 update.

I've disabled ALL extensions. No help. Themes don't seem to make a difference. However, when I went to about:config and entered "toolkit.legacyUserProfileCustomizations.stylesheets" to make it true to allow chrome.css files to work it began immediately. Reset it to false and "X"s are back. Set config to TRUE and it screws up the "X"s. Again, all this is with all extensions off.

I hate the transparency of the tabs and menu bars so I need to set .css files. How else can I do it?

I had a similar problem last year when an auto update came through. After several suggestions didn't help I opted to reinstall a previous version and upgrade that. Now it's back again with the v94 update. I've disabled ALL extensions. No help. Themes don't seem to make a difference. However, when I went to about:config and entered "'''''toolkit.legacyUserProfileCustomizations.stylesheets'''''" to make it true to allow chrome.css files to work it began immediately. Reset it to false and "X"s are back. Set config to TRUE and it screws up the "X"s. Again, all this is with all extensions off. I hate the transparency of the tabs and menu bars so I need to set .css files. How else can I do it?

الحل المُختار

That sounds like a good plan.

For future reference, you can use a site like Pastebin to share non-confidential information -- after you save a paste, it gives you a link you can share.

Also, I suggest adding a comment about the source of each bit of CSS. You can enter a comment into a CSS file using this syntax:

/* From ______ */
Read this answer in context 👍 0

All Replies (6)

more options

Sounds like one of the style rules in your userChrome.css file is causing this problem. What rules do you have related to the X close button, or other buttons on your tab bar?

Note: to share CSS here, type or paste <pre> before your code and </pre> after your code. Otherwise, it is interpreted as wiki text which will make a mess of it.

Since userChrome.css isn't officially supported, I'll mention another site for help with style rules: https://www.reddit.com/r/FirefoxCSS/

more options

I found a screenshot from your July thread. Those are pretty tiny!

more options

Thanks for the response and redirection to Reddit.com.

First of all, I'm not a programmer, just a cut and paste hack. A couple of years ago I found several .css files recommended that worked fine. Now they don't.

Because I can't attach my .css file for review and it's made up of multiple parts, I'm going to try something before I get back to anyone. I'll split my .css file into individual parts and test each one to find which part is causing the problem. Then, once found, I'll take it to Reddit.com for help.

Again, Thanks!

more options

الحل المُختار

That sounds like a good plan.

For future reference, you can use a site like Pastebin to share non-confidential information -- after you save a paste, it gives you a link you can share.

Also, I suggest adding a comment about the source of each bit of CSS. You can enter a comment into a CSS file using this syntax:

/* From ______ */
more options

I found the problem without having to go to reddit.com.

After dividing and trying each segment of userChrome.css I found that blocking out this worked

/* tab close icon size and position */

.tabbrowser-tab:not([pinned]) .close-icon > .toolbarbutton-icon {
  width: 16px !important;
  height: 16px !important;
}

I first tried to change the 16px to 64px but that didn't make any different. Simply inserting /* at the beginning of each line cleared up the problem.

Thanks again for the direction.

more options

Sounds good. You should close the comment off with

*/  

before the next rule or it might also be partially nullified.

Modified by jscher2000 - Support Volunteer