ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Need a fix for sites that use e-mail address's for password authentication.

  • 1 (رد واحد)
  • 1 has this problem
  • 5 views
  • آخر ردّ كتبه jscher2000

more options

I use the password manager in Firefox. Makes it easier to log in to different sites. I have found a situation that has been overlooked. Multiple sites use a persons e-mail address for identity. Different sites then would all use the one e-mail address for identity. Each site however would have a different password. So we have one "name" but multiple passwords connected to that name. Firefox doesnt realize that the one name has multiple passwords so everytime you login to a site that uses your email address as your identity, it asks if you may want to update your password. You have to refuse everytime because the different sites have a different password. If you update the password, each site will now have the password of the last updated password. Its a issue that needs to be fixed so Firefox recognizes how a Email address=Name can have multiple passwords because different sites are using the same name. It looks like Firefox isnt making the connection that different sites are being visited by the same person so some information will be consistent among different sites visited. Thus not realizing that its correct that the "same" name has a password that is different for this new site.

Is there a workaround? thx.

All Replies (1)

more options

Hmm, I have not heard of this problem before. Firefox's password manager has historically stored logins for different sites separately even if you use the same username on those sites. Are the problem logins all under the same domain name (www.example.com, support.example.com, files.example.com)?

The only cross-site feature I'm aware of is the ability to import a login from a different site for a new site where you are using the same username. You could try turning that off and see whether that helps avoid the problem you're experiencing. Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste signon.showAutoCompleteImport and pause while the list is filtered

(3) Double-click the preference to display an editing field, and change the value to null then press Enter or click the blue check mark button to save the change.

More info on about:config: Configuration Editor for Firefox.

Does that have any effect on this issue?

Helpful?

اطرح سؤالا

عليك الولوج إلى حسابك للردّ على المشاركات. من فضلك اطرح سؤالًا جديدًا لو لم يكن لديك حساب بعد.