ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox displays blank pages

  • 17 ردًا
  • 2 have this problem
  • 90 views
  • آخر ردّ كتبه anca.suciu

more options

Hello all,

Although I have just updated Firefox to the last version hoping that the problem might be solved, after using the browser for a while and I google searching something, I get a blank page that does not load. Accessing other websites (bookmarked pages) might work sometimes though, but accessing the home page (google, google translate) just displays a blank page, no error message. I have started Mozilla in safe mode (troubleshooting mode) and the problem persists.

I have already deleted cookies, created a new profile, and reinstalled Mozilla and nothing seemed to work. The behavior is rather unpredictable and odd as I could not identify a pattern for the instances it happens. Exiting the browser and restarting it seems to solve the problem for the moment and then the behavior reoccurs. Also, sometimes after getting blank pages, taking a break or just using other browsers the problem is solved by itself temporarily. This does not happen when accessing Microsoft Edge.

All Replies (17)

more options

Is this only with Google pages?

Delete browsing, search and download history on Firefox {web link}

Remove a single website from your history {web link}

Open the History Manager <Control> (Mac=<Command>) <Shift> H. In the search bar, enter the name of the site. Right-click on one of the listings and select Forget About This Site. This should remove all information, including any site settings And Passwords.

Helpful?

more options

You can check the connection settings.

  • Settings -> General -> Network: Connection -> Settings

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

Helpful?

more options

By the way, I have just noticed that this does not happen if I open a private window. So basically I have a window where google search works (the private session) and one where google search gives me a blank page.

Helpful?

more options

This could be a problem with cache or cookies as PB mode windows do not use the disk cache and use a separate cookie jar.


You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings).

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

You can remove all data stored in Firefox for a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox for this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data for that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data for that website will be saved once again.

Helpful?

more options

Note: Some add-ons are not active when using Private Windows.

Helpful?

more options

Unfortunately I haven't found a solution yet, although I have tried all of the above. (Thank you all for taking the time to reply). I have deleted history (+ forget about this site option), deleted cookies and cache, I use no proxy, and I also opened Mozilla with all add-ons disabled.

Helpful?

more options

Helpful?

more options

I created a new profile and I did not sign in, I have no add-ons, no theme installed and still after using the profile for a while it suddenly displayed no results in google search (although when pressing the load button it starts spinning for a second but nothing happens).

Helpful?

more options

Start Firefox using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?

Helpful?

more options

Yes. Unfortunately the problem persists. But now it seems to be a problem only when google searching something (google translate seems to work now).

Helpful?

more options

Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there?

Starting Any Computer In Safe Mode (web link) Free Online Encyclopedia

https://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/

https://www.digitalcitizen.life/4-ways-boot-safe-mode-windows-10/ +++++++++++++++++++++++++++++++++++++++++++++++ If the problem goes away with the computer in Safe Mode, the problem is with one of the other programs on the system.

As a test, disable your protection programs.

Helpful?

more options

FredMcD said

Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there? Starting Any Computer In Safe Mode (web link) Free Online Encyclopedia https://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/ https://www.digitalcitizen.life/4-ways-boot-safe-mode-windows-10/ +++++++++++++++++++++++++++++++++++++++++++++++ If the problem goes away with the computer in Safe Mode, the problem is with one of the other programs on the system. As a test, disable your protection programs.

I have been using my computer in safe mode for more than two hours and the problem seems to be gone. Still, I have no idea how to resolve the issue, as I do not know what is the trigger.

Helpful?

more options

FredMcD said

If the problem goes away with the computer in Safe Mode, the problem is with one of the other programs on the system. As a test, disable your protection programs.

Helpful?

more options

You can check the connection settings.

  • Settings -> General -> Network: Connection -> Settings

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

You can also do a malware scan just to be sure.

Helpful?

more options

FredMcD said

FredMcD said

If the problem goes away with the computer in Safe Mode, the problem is with one of the other programs on the system. As a test, disable your protection programs.


Unfortunately I cannot do that, as this is a work laptop and I do not have administrator rights to disable protection.

Helpful?

more options

Have you talked to your IT?

Helpful?

more options

FredMcD said

Have you talked to your IT?
( Suggested that I switch to Edge/Chrome, I'm old-fashioned. It just tears my heart apart that I might have to do that as Mozilla is practically unusable for me at this point.

Helpful?

اطرح سؤالا

عليك الولوج إلى حسابك للردّ على المشاركات. من فضلك اطرح سؤالًا جديدًا لو لم يكن لديك حساب بعد.