ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Getting mobile versions of some sites instead of desktop

  • 12 ردًا
  • 1 has this problem
  • 42 views
  • آخر ردّ كتبه chris228

more options

Several days ago, Firefox started giving me what seem to be mobile versions of some sites (mostly Google Drive and Docs) instead of the desktop layouts I want. (It's URL comes up with "mobile" even when I type in the hard way.) The problem does not affect all sites, but it does mess up several daily. I did not deliberately change my preferences or otherwise alter Firefox.

I have tried bringing Firefox up in safe mode and even removing it and downloading it again. No change.

i also "reset the default user agent on Firefox" per this post: https://support.mozilla.org/en-US/questions/1304470

Help would be much appreciated. I like Firefox much better than the alternatives, but if this doesn't get fixed I will have to give up on it.

Many thanks.

All Replies (12)

more options

This issue is unique to Firefox BTW. The websites all work properly in Chrome.

Helpful?

more options

Note that some websites may switch to a mobile layout if they detect that window width is below a specific setting. You can try to make the window wider or zoom the page out to see if that has effect.

Can you post a link to a publicly accessible page (i.e. no authentication or signing on required)?

Helpful?

more options

Page size has no effect. In fact i just had tabs open in the same browser window for 2 different Google accounts. One was only loading mobile while the other was proper desktop. Same size window on both.

I logged into both accounts on Chrome at the same time, same sized window, and they both worked fine so its not a universal setting in the Google account.

Logging out of all Google accounts and restarting resolved it for now on firefox but this keeps happening. I can't keep logging out and quitting multiple times every day.

Recently its only been happening in Google. I can share a screenshot with non-personal info next time it happens.

Helpful?

more options

Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem,

Start Firefox using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?

While you are in Troubleshoot(Safe) mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

Helpful?

more options

Thanks Fred. I tried all these steps earlier except disabling graphics hardware acceleration in Firefox.

I've followed the instructions you provided and will see if that does it. I'm not sure exactly how to reproduce but will update after a week if it doesn't happen. Thanks!

Helpful?

more options

Nope. Google all of a sudden switched to mobile views in Firefox.

See screenshots of Google and Google Drive websites.

I will have to switch browsers if this keeps happening.

Helpful?

more options

Delete browsing, search and download history on Firefox {web link}

Remove a single website from your history {web link}

Open the History Manager <Control> (Mac=<Command>) <Shift> H. In the search bar, enter the name of the site. Right-click on one of the listings and select Forget About This Site. This should remove all information, including any site settings And Passwords.

Helpful?

more options

You can check the connection settings.

  • Settings -> General -> Network: Connection -> Settings

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

Helpful?

more options

I've selected "Forget About This Site" for Google and Google Drive.

I also selected "No Proxy" under "Network: Connection"

Lets see if this works...

Helpful?

more options

I am still getting the mobile version of Google and google Drive after making all of these changes. They work normally for awhile and then and hour or so later they will only load as mobile versions. It seems like Firefox is not compatible with these websites.

Helpful?

more options

Helpful?

more options

I followed these steps. Then spent the afternoon re-entering all of the logins i need to use the web, rebuilding my Bookmarks only to have the problem continue.

FireFox is not working with Google Search, Drive and Maps. I have also noticed the website https://passwordsgenerator.net/ now also loads as if I am on a mobile device, not a desktop.

This is way too much work in order to use a web browser.

Helpful?

اطرح سؤالا

عليك الولوج إلى حسابك للردّ على المشاركات. من فضلك اطرح سؤالًا جديدًا لو لم يكن لديك حساب بعد.