ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Add-ons don't show up in the tool bar or tool bar customization menu (yes they are all enabled and have been turned on and off again)

  • 2 (ردّان اثنان)
  • 1 has this problem
  • 2 views
  • آخر ردّ كتبه cor-el

more options

so for a while now, I don't know exactly but it has lasted throughout several updates, a bunch of my add-ons have decided to not show up in any menu where I can actually use them, they are listen in the actual add-ons manager and they are all enabled and up-to-date. I have un- and reinstalled all of the absentees several times over, I have done the reset thingy in the tool bar customization menu and have followed just about every piece of advice for similar issues on this forum and many others yet the majority of my add-ons still choose to feign non-existence. if it's helpful at all the culprit that alerted me to the problem was the YouTube Enhancer but it actually extends retroactively to add-ons I had installed way before that one that used to work fine. Also, and I can't say this with 100% certainty, I think at this point this problem applies to every new add-on I install, obviously I have only really seen it happen with the few add-ons I installed since this whole thing started so who knows if I'm just having bad luck picking add-ons that are shy. I have also disabled and re-enabled the add-ons that actually work and generally shifted everything around I case the 4 working add-ons are somehow blocking the all the others from being shown. I really really hope someone can help me with this because it's kind of frustrating being completely unable to actually use the majority of my add-ons :/

All Replies (2)

more options

It’s possible that there is a problem with the file(s) that store the extensions registry.

Type about:support in the address bar and press enter.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder

Linux: Under the page logo on the left side, you will see Application Basics. Under this find Profile Directory. To its right press the button Open Directory.

Delete all extensions* files and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

After, restart Firefox.

See "Corrupt extension files"

+++++++++++++++++++++++++++ You will have to approve the updating one last time.

Helpful?

more options

Are you possibly using permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History) as extensions are not enabled automatically in Private Browsing mode ?

Helpful?

اطرح سؤالا

عليك الولوج إلى حسابك للردّ على المشاركات. من فضلك اطرح سؤالًا جديدًا لو لم يكن لديك حساب بعد.