On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

disable history firefox in security param deactivate add-on from working on tool bar

more options

I discover that when I disable history in security param and reboot firefox it deactivate all add-on from working on tool bar. Firefox Ubuntu 88.0.1 (64 bits) Ubuntu 21.04

I discover that when I disable history in security param and reboot firefox it deactivate all add-on from working on tool bar. Firefox Ubuntu 88.0.1 (64 bits) Ubuntu 21.04

All Replies (8)

more options

If you select "Never remember history" or the combination of "Use custom settings for history" + "Always use private browsing mode" then Firefox restarts in a completely private session. Extensions have a separate setting for whether they are allowed to run in private windows. More info in this article: Extensions in Private Browsing. Was that the issue?

more options

Hi Jscher2000 it is only selecting "Never remember history" and if I revert the choice then the add-on are back.

more options

If you do prefer automatic private browsing, you should be able to set your extension to run in private windows. Or didn't that work?

more options

It works yes but it is a counter measure, not the normal behavior. I want to be able to select "Never remember history" and see my add-ons working.

more options

Okay, did you set each extension to have permission to run in private windows, and then test again? Extensions in Private Browsing

more options

Yes it works but again it is odd. Did you face that strange behavior too ?

more options

Note that there is this pref on the about:config page that is false by default.

  • extensions.allowPrivateBrowsingByDefault
more options

Sebu said

Yes it works but again it is odd. Did you face that strange behavior too ?

What is odd? I use normal browsing and just open private windows when needed, so I'm not familiar with the ins and outs of automatic private browsing.