ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox not taking input from userChrome.css

  • 4 ردود
  • 1 has this problem
  • 7 views
  • آخر ردّ كتبه cor-el

more options

My tab bar is way, way too small on Linux. I followed Arch's own documentation on how to fix this by increasing `layout.css.devPixelsPerPx` (mine is at 1.4), and then adjusting font size by editing userChrome.css to select the desired size. Problem is that Firefox won't actually change anything based on what I put in that file. I have set `toolkit.legacyUserProfileCustomizations.stylesheets` to True, and I have attached a photo of my userChrome.css (yes, I'm using nano because Vim is too advanced for my smooth brain). I changed it to a ton of different values and I can confirm that the font size is not actually changing.

Attached screenshots

الحل المُختار

Ha ! I missed in your screenshot that you were using https:// for the @namespace line. This should be http:// to make this work.

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */
Read this answer in context 👍 0

All Replies (4)

more options

The tabbrowser-tabs container has an id and not a class name: #tabbrowser-tabs An individual tab has a class name that can be used as a selector: .tabbrowser-tab

So you can use either one of these (72px would blow the tabs, so make sure to reduce that value):

/* font size for all tab */
#tabbrowser-tabs {
 font-size: 15pt !important;
}

/* font size for an individual tab */
.tabbrowser-tab {
 font-size: 15pt !important;
}

Helpful?

more options

Thanks for the response. Unfortunately this still doesn't work. 72px was a test value to confirm that nothing was actually changing, the value I am actually trying to use is 15px so I changed that

Helpful?

more options

Fixed it - the "@namespace url" line at the top of the file was causing it to not work, so if you run into this question in the future with the same problem as me, delete that line.

Helpful?

more options

الحل المُختار

Ha ! I missed in your screenshot that you were using https:// for the @namespace line. This should be http:// to make this work.

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

Helpful?

اطرح سؤالا

عليك الولوج إلى حسابك للردّ على المشاركات. من فضلك اطرح سؤالًا جديدًا لو لم يكن لديك حساب بعد.