ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Annoying "get latest firefox developer edition version" popup in search bar.

  • 6 ردود
  • 1 has this problem
  • 10 views
  • آخر ردّ كتبه xodecam288

more options

I have firefox developer edition 88.0b9, I have disabled updates using policies.json(DisableAppUpdate: true), so the infamous "update to the latest version" popup with the green icon went away. But now it seems there's another form of those popups that firefox employs. And in the search bar this time. Why aren't they disabled by DisableAppUpdate? How can I disable them using about:config or something of the sort? Pretty sure I've got no malware or anything, always been careful about that kind of thing. Don't have many programs installed. Don't have any addons except an adblocker. All the buttons on that annoying popup lead to official mozilla resources: https://support.mozilla.org/en-US/kb/update-firefox-latest-release https://www.mozilla.org/en-US/firefox/new/ So what do I do with those popups? I have no intention of updating(I don't want any redesigns, any new functionaly, any other things that would disrupt me and change the stuff I'm used to). Only want to disable those popups. That's the entire reason I used policies.json - to disable those annoying popups. But now another form of them appears.

Attached screenshots

All Replies (6)

more options

I don't know what that is called. Looks similar to the kind of snippet you may find on the new tab (Firefox Home) page.

You can file issues related to Policies on Github at https://github.com/mozilla/policy-templates/issues or in Bugzilla at https://bugzilla.mozilla.org/

Helpful?

more options

jscher2000 said

I don't know what that is called. Looks similar to the kind of snippet you may find on the new tab (Firefox Home) page. You can file issues related to Policies on Github at https://github.com/mozilla/policy-templates/issues or in Bugzilla at https://bugzilla.mozilla.org/

Yes it does albeit those have a way to disable them. This snippet does not. It also doesn't always show, only when your query contains some keyword. for example, if I type at least "firefox ma" it pops up. "firefx ma" also works. "firefx max", "firefox max" as well. looks like there's some sort of regex for this snippet.

Helpful?

more options

Note that Firefox 88.0.1 is the current release and current DE is 89.0b8.

So why are you on the DE (aurora) update channel if you do not want to receive its updates and stay with an older beta version and not the final 88 release ?

Helpful?

more options

cor-el said

Note that Firefox 88.0.1 is the current release and current DE is 89.0b8. So why are you on the DE (aurora) update channel if you do not want to receive its updates and stay with an older beta version and not the final 88 release ?

Sorry, I have no idea what those channels are or how they work. I use DE over ordinary firefox because DE has more features(installing unsigned extensions etc.). I do not want to receive any updates because it takes a long time to get used to new interfaces and features. I only update my firefox when I reinstall windows(at that point I can tolerate new interfaces and stuff because everything else is also new). I just fetch the latest firefox version available, beta or whatever, and disable updates and sit there. As insecure and retarded as that may be, that's my choice and I always loved firefox because it respects my choices and provides a ton of settings that allow me to change anything I want in the browser. And disabling updates is one of such settings. But now there's a popup that basically ignores that setting and asks me to update even though updates are explicitly disabled. And I want to know how to get rid of that popup if it's possible.

Helpful?

more options

It looks like Recommendations from Firefox. You can find in the article how to turn it off.

Helpful?

more options

TyDraniu said

It looks like Recommendations from Firefox. You can find in the article how to turn it off.

Thanks, but that wasn't it. I already had that disabled long ago. The popup is still there.

Helpful?

اطرح سؤالا

عليك الولوج إلى حسابك للردّ على المشاركات. من فضلك اطرح سؤالًا جديدًا لو لم يكن لديك حساب بعد.