ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox history dsiplayed with incorrect timezone

more options

I am running Firefox 88.0 (64-bit) on Windows 10 Pro (64-bit) 20H2. I don't think the exact versions are the problem though, because this has been going on for months at least.

My system time zone is manually set to "Haiti (UTC+5:00)" for the Caribbean. My system time is set to automatically sync and my system time zone is set to manual.

The problem is if I open my Firefox browser history with Library > History > Manage History the visit time is an hour later than my system time. For example the history will show a page visit at 14:20 while my system time is still 13:20.

I suspect that Firefox is using the wrong time zone offset, but where can I change that?

Thanks.

All Replies (6)

more options

every year, the u.s.a. changes the time the clock to be 1 hour ahead during the spring and summer.

then it goes back 1 hour during fall and winter.

this is also called "daylight savings time"

Helpful?

more options

That is true, and I am well aware of daylight savings time. But the USA is not the whole world and many other countries don't use daylight savings. That is why I said my system time zone is manually set, because I don't use daylight saving.

But lo-and-behold, you learn something new every day! In all the Caribbean which generally does not use daylight saving, Haiti *does*!

My system time is set to that time zone but with automatic daylight saving off. Windows obviously respects that daylight saving is disabled and the time stays correct, but Firefox is only looking at the time zone.

Helpful?

more options

To confirm, I changed my Windows time zone to "Bogota, Lima, Quito, Rio Branco (UTC-5:00)" which does not observe daylight savings and the history is showing the correct time.

This is a bug in Firefox: Windows respects the "Adjust for daylight saving time automatically" setting, but Firefox does not.

Modified by nicolas.noakes

Helpful?

more options

i see.

i am not sure how to fix this issue in FF.

but i eagerly await for someone else to let us know !  :-)

Helpful?

more options

Paste each of these one at the time in the command line of the Web Console and press Enter to see the result.

  • (new Date());
  • (new Date()).toString();
  • (new Date()).toLocaleString("en-US",{weekday:"long",day:"numeric",month:"long",year:"numeric",hour:"numeric",minute:"numeric",second:"numeric",hour12:false,timeZoneName:"short"});

Helpful?

more options

@cor-el

(new Date()); Date Wed May 05 2021 12:38:20 GMT-0500 (Eastern Standard Time)

(new Date()).toString(); "Wed May 05 2021 12:38:27 GMT-0500 (Eastern Standard Time)"

(new Date()).toLocaleString("en-US",{weekday:"long",day:"numeric",month:"long",year:"numeric",hour:"numeric",minute:"numeric",second:"numeric",hour12:false,timeZoneName:"short"}); "Wednesday, May 5, 2021, 12:38:38 EST"

(Note my reply of 30 April, that I have changed my system timezone from one which observes daylight savings to one that does not.)

Helpful?

اطرح سؤالا

عليك الولوج إلى حسابك للردّ على المشاركات. من فضلك اطرح سؤالًا جديدًا لو لم يكن لديك حساب بعد.