ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't login to citi.com with Firefox.

  • 7 ردود
  • 1 has this problem
  • 359 views
  • آخر ردّ كتبه FredMcD

more options

I can no longer sign into my Citi account using Firefox (85). Works on all other browsers. The only error message I get is:

Trouble signing on?Select "Forgot User ID or Password"

Started a few days ago. Contacted Citi, and they ran me through all the typical solutions (clearing cache, force refreshing, etc.) There final solution was to use another browser.

Checked on my laptop, which is still using Firefox (v84.0.2). I could login with no issue. Updated to v85.0 and I cannot login.

So, there is an issue with v85.0 and citi.com

I can no longer sign into my Citi account using Firefox (85). Works on all other browsers. The only error message I get is: '''Trouble signing on?Select "Forgot User ID or Password"''' Started a few days ago. Contacted Citi, and they ran me through all the ''typical'' solutions (clearing cache, force refreshing, etc.) There final solution was to use another browser. Checked on my laptop, which is still using Firefox (v84.0.2). I could login with no issue. Updated to v85.0 and I cannot login. So, there is an issue with v85.0 and citi.com

الحل المُختار

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

Read this answer in context 👍 0

All Replies (7)

more options

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

more options

I restarted with add-ons disabled. I could login. I then restarted with add-ons enabled, and I could login. Not sure what to think of that.

At any rate, it's working now.

Thank you!

more options

Glad to help. Safe Surfing.

more options

I'm having to restart with add-ons disabled, login, then restarted with add-ons enabled, several times a day. I can't pinpoint if it's a specific add-on causing the issue (since I manually disable them, and cannot login).

more options

الحل المُختار

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

more options

Looks like the culprit is Privacy Possum.

more options

Well done.