ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Quora images are broken on Firefox

more options

When I visit quora.com on Firefox, I get broken images. This doesn't happen with Edge or Chrome, and of course not on my other devices (so not a network/firewall issue). It seems to be only on Quora so far.

I tried deleting cache, refreshing the browser, creating a new account, running without add-ons or plugins, without success. Switching off the enhanced tracking protection doesn't help either. I am running out of options...

The only thing I can think off, is that the browser was installed with admin rights that I do not have anymore, although it still updates without errors.

Can anyone help?

Attached screenshots

الحل المُختار

If the signing certificate is in the Windows certificate store (for example, IE and Chrome trust it), you could set Firefox to trust everything that Internet Explorer trusts by having it check for authority certificates in the Windows certificate store.

1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

2) In the search box above the list, type or paste root and pause while the list is filtered

3) Double-click the security.enterprise_roots.enabled preference to switch the value from false to true

Try the site again on another tab. You may need to restart your browser.

Read this answer in context 👍 1

All Replies (10)

more options

http://kb.mozillazine.org/Images_or_animations_do_not_load

https://support.mozilla.org/en-US/kb/fix-problems-images-not-show


Make sure you are not blocking content.

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Helpful?

more options

That didn't help. It turns out that when I look closer, qph.fs.quoracdn.net where images are hosted is apparently not trusted by Firefox because its certificate is not valid. Even if I approve once the site, when I reload, the image is blocked again. How to fix that issue?

Helpful?

more options

Last reply by vincent.arnoux 3 hours ago

Sorry, current forum security sometimes delays the posting of messages. And in turn, we are not notified of those posts.


because its certificate is not valid

What is/are the exact error message(s) ?

Helpful?

more options

My reply has been posted but is pending moderator approval apparently.... The message is the "Warning: Potential Security Risk Ahead" screen with "SEC_ERROR_UNKNOWN_ISSUER"

Helpful?

more options

No problem here with the certificate. I notice that is has been renewed a few weeks ago (Jan 17, 2021).


Try to rename the cert9.db file (cert9OLD.db) and remove the previously used cert8.db file in the Firefox profile folder with Firefox closed to remove intermediate certificates and exceptions that Firefox has cached.

If this has helped to solve the problem then you can remove the renamed cert9OLD.db file. Otherwise you can undo the rename and restore cert9.db.

Helpful?

more options

That was a good idea, but unfortunately didn't work... When I click on the picture details to get the path to the CDN, I get the certificate error message. If I accept the risk, I do see the image, but not if I reload the page.

Modified by vincent.arnoux

Helpful?

more options

Can you click the blue SEC_ERROR_UNKNOWN_ISSUER text (second screenshot) and copy the base64 encoded certificate text to a reply so we can check the certificate ?

Helpful?

more options

Interestingly, although the problem persisted for 3 months, when I tried to get the certificate text and repeated the steps, the images appeared (not broken anymore). I then refreshed the page, and the broken links got fixed. That is very strange, the only thing I changed was to rename the cert9.db certificate, then move it back as it didn't work. I am guessing it is somehow related.

In any case, many thanks to co-rel!

Helpful?

more options

الحل المُختار

If the signing certificate is in the Windows certificate store (for example, IE and Chrome trust it), you could set Firefox to trust everything that Internet Explorer trusts by having it check for authority certificates in the Windows certificate store.

1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

2) In the search box above the list, type or paste root and pause while the list is filtered

3) Double-click the security.enterprise_roots.enabled preference to switch the value from false to true

Try the site again on another tab. You may need to restart your browser.

Helpful?

more options

This is the solution that actually solved my problem long term. The previous one would revert to not displaying images after some time. Thanks a lot for having posted.

HK said

If the signing certificate is in the Windows certificate store (for example, IE and Chrome trust it), you could set Firefox to trust everything that Internet Explorer trusts by having it check for authority certificates in the Windows certificate store. 1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful. 2) In the search box above the list, type or paste root and pause while the list is filtered 3) Double-click the security.enterprise_roots.enabled preference to switch the value from false to true Try the site again on another tab. You may need to restart your browser.

Helpful?

اطرح سؤالا

عليك الولوج إلى حسابك للردّ على المشاركات. من فضلك اطرح سؤالًا جديدًا لو لم يكن لديك حساب بعد.