ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to disable the Reload/Stop button animation?

  • 3 ردود
  • 1 has this problem
  • 27 views
  • آخر ردّ كتبه Vuca

more options

Every time a link is clicked or the page is refreshed, the Reload/Stop button plays an animation of the reload arrow morphing into an X and then back into a reload arrow.

This is very distracting. How can the user disable this animation?

Help guides from 2017 say to change the following about:config prefs: browser.stopReloadAnimation.enabled toolkit.cosmeticAnimations.enabled But these do not exist anymore.

الحل المُختار

There is a new preference to reduce animations. It doesn't prevent the Reload button from switching to Stop during loading, but there is less bounciness, if that's a word. (This overrides the system-level setting regarding reduced motion for purposes of what happens in Firefox.)

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste the new preference name

ui.prefersReducedMotion

If this preference was already created and shows a value of 0, skip to step (4).

(3) On the bar with the bolded preference name, click the radio button next to Number and click the + button to add the preference. Then Firefox should display the new value.

(4) Set the value to 1 (double-click to edit if necessary) and click the blue checkmark button to save the change.

Screenshot sequence for reference: https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2020-06-16-08-44-24-3a976a.png

What do you think?

Read this answer in context 👍 1

All Replies (3)

more options

Try to add ui.prefersReducedMotion = 1.

Helpful?

more options

الحل المُختار

There is a new preference to reduce animations. It doesn't prevent the Reload button from switching to Stop during loading, but there is less bounciness, if that's a word. (This overrides the system-level setting regarding reduced motion for purposes of what happens in Firefox.)

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste the new preference name

ui.prefersReducedMotion

If this preference was already created and shows a value of 0, skip to step (4).

(3) On the bar with the bolded preference name, click the radio button next to Number and click the + button to add the preference. Then Firefox should display the new value.

(4) Set the value to 1 (double-click to edit if necessary) and click the blue checkmark button to save the change.

Screenshot sequence for reference: https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2020-06-16-08-44-24-3a976a.png

What do you think?

Helpful?

more options

The chosen solution fixes the problem.

(Make sure it's Number = 1 and not Boolean = true.)

Alternatively you can remove the Reload/Stop button from the bar via the ☰ → "Customize..." button, and only use the Reload button in the right-click menu if you ever need it. Or hit F5.

Helpful?

اطرح سؤالا

عليك الولوج إلى حسابك للردّ على المشاركات. من فضلك اطرح سؤالًا جديدًا لو لم يكن لديك حساب بعد.