ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Google defaults to Czech while all other sites and programs set to English

  • 9 ردود
  • 1 has this problem
  • 7 views
  • آخر ردّ كتبه ace910046sca1

more options

For reasons unknown to me, Google currently defaults to Czech when I'm using Firefox even though Firefox itself, my VPN, and my computer all are set to default to English. My VPN is also set for the US. The fact that my default browser is not Google should be irrelevant as even that search engine is set to English. Whenever I try to log into Chrome, the default is still and always English. I cannot find any settings anywhere in either Firefox or my computer that would cause Google to default to any language other than English. Please help.

All Replies (9)

more options

Log into Google, go to the profile page, and check the language setting.

Helpful?

more options

That was one of the first things I verified. Google defaults to English before and after login on my Android mobile phones and when I open Chrome browser on my computer. All of the language settings on my computer are set to English, including Firefox. Any time I log out of Google and close Firefox, the next time I go to log into Firefox Google defaults to Czech rather than English. It's when I reopen Firefox ad re-log into Google that it defaults to Czech again, even though Google's setting were saved to English.

Helpful?

more options

When you go to the Google page, is it in English? Then changes after logging in? Are you using a bookmark? Try going to the site from https://www.google.com/

Helpful?

more options

It turns out that the problem is more specifically Gmail that's stuck defaulting to Czech. Whenever I update Firefox, I'm having to re-log into Gmail (annoying but acceptable), but the initial page where it describes Gmail and has the links to either log into your account or create an account defaults to Czech. Even after resetting the page to English, when I go to log in to my account it once again defaults to Czech. I've also sent a message to Google about it to see what they have to say.

Helpful?

more options

That was very good work. Well Done. Please flag your last post as Solved Problem as this can help others with similar problems.

Helpful?

more options

The problem is NOT solved. While the problem has been narrowed down in scope it still persists. Big surprised, not a peep from Google about this problem, either. So how about we find an actual solution rather than wishful thinking.

Helpful?

more options

In answer to a previous query, no I am not trying to access my Gmail account (nor any other Google product) via a bookmark.

Helpful?

more options

Have you ever connected to VPN servers in Czech, or maybe you have done something with custom DNS settings in Firefox?

Try wiping all of cookies and history (warning, maybe you have something important that you are logged in with Firefox currently) and then check Gmail again. Cheers!

Helpful?

more options

None of the VPNs I've ever used, including the one I'm currently using, have ever been set to the Czech language nor set to show as being anywhere in the Czech Republic. Google Maps, OTOH, yesterday defaulted to being somewhere in that country even after I'd already been logged into Gmail and set to the English language. If I didn't know better (and I'm not claiming to know better), I would almost think Google is trying to get me to reveal more about myself than I'm comfortable with any large corporation knowing. That it's largely happening when I'm using my Firefox browser is interesting.

I've already tried clearing out all cookies in Firefox, none of my Firefox settings and none of the programs I use are set to Czech as anything more than one of all the available language settings, and I've only ever had my language settings set English.

Helpful?

اطرح سؤالا

عليك الولوج إلى حسابك للردّ على المشاركات. من فضلك اطرح سؤالًا جديدًا لو لم يكن لديك حساب بعد.