ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Addons icons don't appear in toolbar

  • 2 (ردّان اثنان)
  • 1 has this problem
  • 59 views
  • آخر ردّ كتبه fastriver

more options

When I opened Firefox this morning, I got a pop-up I've never seen before, that said something like "Firefox is slow. Refresh Firefox." So I did that. Then I added back the add-ons I want to use. The add-ons are installed and working. But there are no icons in the toolbar. There is no overflow arrow. Just a blank space where the icons used to be. I've searched for solutions for two hours now. Can't figure it out.

Attached screenshots

الحل المُختار

The blank space is likely the flexible (spring) items that appear by default at the left end and the right end of the location bar and search bar. You can remove these spaces via the right-click context menu or drag them in customize mode off the toolbar to the palette window.

You can try to clear the startup caches via the "Help -> Troubleshooting Information" (about:support) page. Also make sure that you aren't in permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History).

If that didn't work then try to remove extensions.json in the profile folder with Firefox closed.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Read this answer in context 👍 1

All Replies (2)

more options

الحل المُختار

The blank space is likely the flexible (spring) items that appear by default at the left end and the right end of the location bar and search bar. You can remove these spaces via the right-click context menu or drag them in customize mode off the toolbar to the palette window.

You can try to clear the startup caches via the "Help -> Troubleshooting Information" (about:support) page. Also make sure that you aren't in permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History).

If that didn't work then try to remove extensions.json in the profile folder with Firefox closed.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Helpful?

more options

Absolutely correct. So simple once you explained... but impossible to figure out on our own. I wonder if Firefox should reconsider the default configuration there. Thank you so much.

Helpful?

اطرح سؤالا

عليك الولوج إلى حسابك للردّ على المشاركات. من فضلك اطرح سؤالًا جديدًا لو لم يكن لديك حساب بعد.