ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I have updated my O/S from Ubuntu 18.04 to 20.10. Nothing else. Now Firefox is nearly useless

  • 39 ردًا
  • 1 has this problem
  • آخر ردّ كتبه teeny_weeny

more options

This is basically a copy of what I put in the Ubuntu forum. The problem is the same, no matter where I post it.

Originally I was using Ubuntu 18.04 LTS.

I thought it would be good to update to GG (20.10) though I did briefly try FF (20.04).

As the install was done on an existing 18.04 version things remained the same for programs, book marks, etc.

Ok, now the crunch: I USE Firefox ""A LOT"". When it loads, there are...... 8 x 6 windows of FireFox and each of those have anywhere from one to ""THIRTY"" tabs loading.

Believe me: ""It worked!!""

I could use it, also run other tasks as well - though a VM was pushing it with the RAM. But the entire machine worked.

Now, I am lucky if FireFox loads at all. Let alone let me browse.

When it loads some of the window's tops are flashing. A screen shot does not really show this. (I tried)

All that has changed is the O/S from 18.04 and Firefox from (what ever it was) to 83.0

I don't want this to be a finger pointing exercise between Mozilla and Ubuntu. I would prefer it is helpful to all.

What have I tried? I've tried starting FireFox with all addons disabled. Still happens.

I am going to try to remember to (next time) launch FireFox from a Terminal and pipe the output to a file to look for things.

The machine I am using has shown it is well up to being able to have this running. I have had it working for a few years like this.

This post is (for now) to establish there is a problem. I will post more information when I get it, rather than waiting to get it then post, as I feel there are a lot of people who have very similar problems and I want it known: ""You are not alone!""

Now a bit of extra stuff.

Other things which are weird: When I am watching stuff - youtube for example - the playback is/WAS jerky. I hadn't touched anything in the settings.

After digging around, I discovered that I had to turn ""OFF"" the hardware acceleration for the graphics. Question: How did it get turned on? (Semi rhetorical)

I have a lot of local pages I open with passwords. When I load them the CPU load goes through the roof and nearly invariably the program just exits. No crash report.

Which is a good 50% of how it happens. The other 50% is the machine just locks up and I have to power it down.

الحل المُختار

24 Dec 12:18 (local)

I have had Firefox running now for a while (on this session) and though I may not have flogged it that hard, I have been on a video conference for 2 hours and not a glitch.

It may be the extra 16 gig of memory has fixed (resolved?) the problem I was having.

Read this answer in context 👍 0

All Replies (19)

more options

Thanks both for the ideas.

I have just "reinstalled" Firefox and it noted some "no longer needed stuff to be removed".

I did `sudo apt autoremove` to get rid of it.

This is now a whole new chapter.

Ok, what has been happening in the mean time:

I made a second profile. I exited firefox and looked at the two directories. Few file/directory differences. The problematic one has other/extra files/directories.

I checked and deleted the directories (they were empty anyway). No change.

Where the bookmarks/previous session data is is not quite as I read it.

There is a `sessionstore-backups` directory and it has files like: previous.jsonlz4 and recovery.baklz4

I saw mention of them before but not pointing to the directory they are in.

A "problem" is that I can launch the new (test) profile/session but..... None of the previous session data is loaded and so firefox is running with no load. (Like the 47 windows I now have).

Yes, I am not taking in the information given that well. My problem/fault. Sorry. But it would be nice to get the newly created session to have the same windows/tabs open to compare between the two.

Another thing which has been thought: Can I roll back firefox to..... 82.x? That way to help find out if 83.x isn't the problem. I am sure very VERY few people would use it (firefox) as *hard* as I do, and though maybe not a good thing, the problems I am seeing/causing/(what ever) wouldn't be seen by most people.

I'll stop here, as I have asked a few questions.

Again: Thanks to both for the replies today.

Now I am using the original profile but have reinstalled firefox.

I'll take it around the block a few times and let you know what is happening.

Oh, just remembered another piece of the puzzle. "Exiting firefox". Um........ Usually I don't. I turn on the PC. Load firefox and it is used until I turn the PC (NUC) (Ubuntu) off. These days it is either: It just exits - no error. Annoying. Or: the whole PC locks up and I have to power cycle it.

Modified by teeny_weeny

more options

Mostly (or, perhaps, totally) irrelevant, but 20.04 is the LTS for a reason... Also, next time before having to do somersaults, Firefox has a Help menu option: "Restart with Add-Ons Disabled". :)

From your writing (and screens) I can see that you're using some unknown (and quite possible totally wrong, or even possibly dangerous) ad-block software and sometimes these can be malicious clones, even straight up forks (with rogue code simply added in) of other "real" blockers - that are designed to provide back doors into your system and such stuff (precisely because they're popular software and lots will use it).

The only two ad-blockers that should (ever) be considered are Adblock Plus (from adblockplus.org) and what came after, but quickly surpassed it as the former went somewhat the commercial route: uBlock Origin (hosted at: https://github.com/gorhill/uBlock). With today's PCs and over 8GB of RAM, it needs to have all four "Privacy" options toggled in settings and all filter lists can be enabled, except for the last one "Regions, languages" at the bottom.

Other than that, just a few more Add-ons such as: HTTPS Everywhere (by eff.org - LOL, I feel like I have to list what the "real" originals are for all of 'em, since you seem to be using some dodgy ones), Decentraleyes (by Thomas Rientjes), then Privacy Badger - for redundancy, really, only (it's by eff.org again) and that kinda covers all of the basics... What's left is an EXTENSIVE configuration of about:config to disable all trackers, reports, beacons, pings, offline stores that can be exploited - if they somehow manage to get past all of the filters, mostly legitimate companies doing tracking, data harvesting and privacy invasion (including your ISP probably) and, for example, this is the template that I use to edit to my needs: https://github.com/arkenfox/user.js/

Lots of it is for tor and is on by default and crippling a "normal" browsing experience, so that it has to be turned (back) off; but, there are some useful things - like running from memory only, to preserve the SSD /NVMe drives (and phone storage, too - also by increasing the value for browser.sessionstore.interval so that it writes that less often, too), while keeping offline stores disabled and some workers disabled and some simple stuff, like allowing for menus where web designers try to get cute - this is by toggling dom.event.contextmenu.enabled to false and while you're there, you can secure your clipboard with: dom.event.clipboardevents.enabled and disable the attack vector: extensions.screenshots.disabled

... Hope it helps. :D

more options


Ok, what I "used to have": The name is/was adsblocker. From what I could see it was supposed to be good.

Now I have adblocker ultimate.

Restarting firefox with addons disabled is fine. But the catch is this: As is, I have a lot of windows (tabs) open. I'm guessing 3 digits and possibly mid range.

I don't know how to ask firefox how many tabs it has open.

I was running 18.04 and had only just updated to 20.10 (via a quick stop off at 20.04) The SSD got corrupted (I'll call it that. That is a whole other story) and I didn't have a working machine for 4 weeks. I was booting form a rescue USB and the drive data was intact. Just not booting.

I got it back up and working to where it was before. But the added complication is/was that firefox had just updated itself too.

Anyway, back to the "with addons disabled": I'll try it again but from memory it doesn't give me back all the windows/tabs I had.

So I am comparing "apples" with "oranges". the new session works with the addons disabled, but it also doesn't have anywhere near the same load with open windows. So I can't say if it does fix the problem or not.

What I am thinking of doing - and need help to do it - is roll back to firefxo 82.0.x rather than 83.0 and try that.

I don't know where to get the .deb package though.

more options

If your Firefox isn't set to restore the previous session automatically, can you restore it from the menu? Either:

  • "3-bar" menu button > Restore Previous Session
  • (menu bar) History > Restore Previous Session

If they are missing or grayed, check either:

  • "3-bar" menu button > Library > History > Recently Closed Windows
  • "Library" toolbar button > History > Recently Closed Windows
  • (menu bar) History > Recently Closed Windows
more options

As is, it restores the previous session. But that is in the original (problematic) profile.

I have tried to copy the "previous session" data to the new profile, but it isn't loaded when I start firefox.

Do I need to copy the entire directory or just the couple of files?

more options

teeny_weeny said

Do I need to copy the entire directory or just the couple of files?

I don't want to predict what files Firefox will want and which it won't. I suggest replicating the set in the test profile with the one from the earlier profile as suggested earlier:

jscher2000 said

Probably you will want to test your regular session history file in the new profile. It's a little late for me to go through that in full detail, but as you may know, those files are:
  • [oldprofile.folder]\sessionstore.jsonlz4 => only exists after Firefox does a normal shutdown
  • [oldprofile.folder]\sessionstore-backups => live files and archives from recent updates
Rather than delete any files or folders, rename the ones in your new profile
  • [newprofile.folder]\sessionstore.jsonlz4 => sessionstoreOLD.jsonlz4
  • [newprofile.folder]\sessionstore-backups => sessionstore-backupsOLD
This is to avoid major regrets if you happen to copy files in the wrong direction.
more options

I appreciate your reply, but there is something I am not getting.

(and sorry I can't do the fancy copy/paste/quite stuff)

Probably you will want to test your regular session history file in the new profile. It's a little late for me to go through that in full detail, but as you may know, those files are:

    [oldprofile.folder]\sessionstore.jsonlz4 => only exists after Firefox does a normal shutdown
    [oldprofile.folder]\sessionstore-backups => live files and archives from recent updates

I can not resolve that.

Ok, `oldprofile.folder`. with you. `\sessionstore.jsonlz4` that and the other file you mention don't exist. Either of them.

The closest I can get is `oldprofile.folder/sessionstore-backups/` but in there there are only these files:

me@me-desktop:~/.mozilla/firefox/3if3jzih.default/sessionstore-backups$ ls previous.jsonlz4 upgrade.jsonlz4-20190718161435 recovery.baklz4 upgrade.jsonlz4-20201014125134 recovery.jsonlz4 upgrade.jsonlz4-20201112153044 me@me-desktop:~/.mozilla/firefox/3if3jzih.default/sessionstore-backups$

For the sake of all cards on the table this is the directory of the `oldprofile` directory:

(I have to do it this way, if I just do file names it is a mess.)

me@me-desktop:~/.mozilla/firefox/3if3jzih.default$ ls -l total 94140 -rw------- 1 me me 13716 Dec 3 06:57 addons.json -rw------- 1 me me 4526 Dec 3 12:12 addonStartup.json.lz4 -rw-rw-r-- 1 me me 0 Dec 2 15:56 AlternateServices.txt -rw------- 1 me me 527568 Jan 21 2020 blocklist.xml drwx------ 2 me me 4096 Dec 2 06:58 bookmarkbackups -rw------- 1 me me 216 Dec 3 12:11 broadcast-listeners.json drwx------ 27 me me 4096 Dec 1 10:18 browser-extension-data -rw------- 1 me me 245760 Jan 26 2018 cert8.db -rw------- 1 me me 491520 Sep 25 14:07 cert9.db -rw-rw-r-- 1 me me 0 Nov 26 18:31 ClientAuthRememberList.txt -rw------- 1 me me 160 Dec 3 12:09 compatibility.ini -rw------- 1 me me 939 Sep 12 2018 containers.json -rw-r--r-- 1 me me 229376 Dec 1 10:29 content-prefs.sqlite -rw-r--r-- 1 me me 1572864 Nov 26 18:24 cookies.sqlite -rw-r--r-- 1 me me 32768 Oct 25 2018 cookies.sqlite-shm -rw-r--r-- 1 me me 0 Dec 3 12:09 cookies.sqlite-wal drwx------ 3 me me 4096 Dec 3 12:10 crashes drwx------ 3 me me 4096 Dec 3 12:11 datareporting -rw------- 1 me me 21 Nov 16 2017 dh-ldata.json -rw-rw-r-- 1 me me 173 May 10 2020 enumerate_devices.txt -rw------- 1 me me 1297 Dec 1 15:23 extension-preferences.json drwx------ 3 me me 4096 Dec 3 06:57 extensions -rw------- 1 me me 1700 Dec 3 12:09 extension-settings.json -rw------- 1 me me 75939 Dec 3 12:12 extensions.json -rw-r--r-- 1 me me 26476544 Dec 3 12:11 favicons.sqlite -rw-r--r-- 1 me me 32768 Oct 25 2018 favicons.sqlite-shm -rw-r--r-- 1 me me 2098720 Dec 3 12:11 favicons.sqlite-wal -rw-r--r-- 1 me me 360448 Dec 3 08:54 formhistory.sqlite drwxr-xr-x 3 me me 4096 Oct 31 2019 gmp-gmpopenh264 -rw------- 1 me me 2709 Oct 29 15:18 handlers.json -rw------- 1 me me 294912 Mar 12 2018 key4.db -rw------- 1 me me 16300 Dec 2 14:53 logins-backup.json -rw------- 1 me me 16300 Dec 3 08:54 logins.json drwx------ 2 me me 4096 Sep 25 16:15 minidumps -rw------- 1 me me 36 Dec 3 09:33 notificationstore.json -rw-r--r-- 1 me me 98304 Dec 3 09:40 permissions.sqlite -rw------- 1 me me 877 Jan 26 2018 pkcs11.txt -rw-r--r-- 1 me me 41943040 Dec 3 12:09 places.sqlite -rw-r--r-- 1 me me 32768 Oct 25 2018 places.sqlite-shm -rw-r--r-- 1 me me 4096000 Dec 3 12:11 places.sqlite-wal -rw------- 1 me me 172 Jan 15 2020 pluginreg.dat -rw------- 1 me me 23389 Jun 2 2020 prefs-1.js -rw------- 1 me me 27077 Dec 2 08:14 prefs-2.js -rw------- 1 me me 27466 Dec 3 12:12 prefs.js -rw-r--r-- 1 me me 65536 Dec 3 12:10 protections.sqlite drwx------ 2 me me 12288 Dec 3 12:11 saved-telemetry-pings -rw------- 1 me me 487 Dec 3 12:09 search.json.mozlz4 -rw------- 1 me me 16384 Oct 31 2017 secmod.db -rw-rw-r-- 1 me me 0 Nov 26 18:31 SecurityPreloadState.txt drwxrwxr-x 2 me me 4096 Apr 12 2020 security_state -rw-rw-r-- 1 me me 2 Nov 26 18:24 serviceworker.txt -rw------- 1 me me 90 Dec 3 12:09 sessionCheckpoints.json -rw-rw-r-- 1 me me 1323 Nov 12 2017 session.rdf drwx------ 2 me me 4096 Dec 3 12:12 sessionstore-backups -rw------- 1 me me 7285 Dec 3 06:54 shield-preference-experiments.json -rw------- 1 me me 84 Mar 16 2018 shield-recipe-client.json -rw-rw-r-- 1 me me 46105 Dec 3 09:54 SiteSecurityServiceState.txt drwxr-xr-x 5 me me 4096 Nov 6 2019 storage -rw-r--r-- 1 me me 8704 Dec 3 12:09 storage.sqlite -rw-r--r-- 1 me me 131072 Aug 17 2018 storage-sync.sqlite -rw-r--r-- 1 me me 32768 Oct 26 08:41 storage-sync-v2.sqlite -rw-r--r-- 1 me me 32768 Nov 26 18:33 storage-sync-v2.sqlite-shm -rw-r--r-- 1 me me 327952 Oct 26 08:41 storage-sync-v2.sqlite-wal -rwx------ 1 me me 29 Oct 31 2017 times.json drwx------ 5 me me 4096 Apr 19 2018 weave -rw-r--r-- 1 me me 15859712 Dec 3 06:57 webappsstore.sqlite -rw-r--r-- 1 me me 32768 Oct 25 2018 webappsstore.sqlite-shm -rw-r--r-- 1 me me 1082168 Dec 3 06:57 webappsstore.sqlite-wal -rw------- 1 me me 8733 Dec 3 12:12 xulstore.json me@me-desktop:~/.mozilla/firefox/3if3jzih.default$

The "test" profile.... I am not too worried about.

Just now it is painful getting firefox to load long enough to even change profiles.

It is now using the new/TEST profile. But as I have said: I don't get the windows open from the main profile so am not really testing much. I am not seeing the files you mention/name, so I can't get to that point.

more options

Ok, newer update:

I created a THIRD profile. (ANOTHER_TEST) and copied all the stuff from the MAIN (problematic) profile to this.

Started firefox then restarted it with "all addons disabled".

I'll take it for a spin around the block and see what it does.

Interestingly just now, looking at the LOAD graph, it is lower than it is with the main profile. Just a point to note.

Ok, something I just noticed - and I have mentioned this before I think but then it was slightly different:

I copy my profile data from one profile to another. It loads, but one window isn't there. Originally when I first saw this it was the window with my e-mail and this discussion on/in it.

Now, it is the window with all my youtube tabs. Which may be why the load is lower. (Who knows?)

But I shall now open a new window and go crazy with youtube - well I will try. All the ads (with no ad blocker) really kills youtube for me.

Ok, I'll have to now say I was wrong. There does seem to be a youtube window. Originally I opened a new window and started to type youtube.com..... The browser prompts me and if there is a tab of that name it is shown.

Hand on my heart, it wasn't there originally. After I posted this observation and started to do that, I was then offered an existing (open?) tab at youtube.com

Sorry. But I want to mention this as it may be helpful in finding out what is going on.

Modified by teeny_weeny

more options

Big update:

I have updated to firefox 83.0.2

Things have become a bit nicer.

But no promises just yet. CPU load way down on what it was with 83.0.0

more options

teeny_weeny said

Hang on. > Firefox will switch your default profile to the new one, so click the Set as Default Profile button for your regular one to avoid an unwanted surprise at your next startup. Oh, sorry. Ok. I don't mind rebooting and loading it in the "new profile" and give it a go. Then, if all goes pear shaped, I could load Firefox and switch back to the original profile. Is there a way I could copy all the open sessions in the "suspect" profile into the new one? That way it will get a good test. It will take a lot of time for me to open that many tabs again. This is a screen shot of the tabs.... Note: Those are only the windows! Some have a lot of tabs!

Gee, do you think that a thoughtful browser designer might introduce "profiles" that based on specific configurations that matter to the user, depending on what the browser is being used for? That is what most people would call a feature. The less a browser gets in the way of a user, the better, with very few exceptions.

Think of the Big Red Switch, Ctrl-Alt-Del, or "FORMAT *.*" on early PCs -- it should never be easy to make widespread, permanent, or otherwise seriously regrettable unwanted changes to a computer or other important/complex system. Humans are, well, human.

They also tend to oversimplify things which should have been made reasonably easy and straightforward in the first place.

So far, there has never been any explanation of why a user's preferred Firefox browser configuration should not persist through any but the most extreme changes that come with a truly significant release, such as "Quantum", are not very carefully backed up and then left unchanged when the new version starts up.

Why is preserving a user's preferred configuration not a high priority concern for the Firefox developers at Mozilla?

The deafening silence in response to above question when I have asked in the past suggests that nobody can come up with a plausibly good excuse for the factory-reset-by-design defect. I am still waiting to see even a pathetically lame excuse. Maybe it could involve a collusion with President Trump, but those never seem to withstand much scrutiny.

The next Firefox update should leave all user configurations intact and back the existing installation up so that a few clicks will restore it to the way it was before the update, if the user thinks the update made things too different, just plain unusable or worse.

Sync makes some sense for people who were born with an attached smartphone, but not for those who prefer using platforms that have (multiple) large displays with at least one connected via HDMI, full-size keyboards with extra function buttons, and three or four USB 3.0 (or better) ports.

Me? I figure that anyone who gets hit while ignoring the DON'T WALK signal at a cross walk ought to pay for any resulting damage to the vehicle(s) involved. (Call it evolution in action.)

Seriously, I do not use Firefox on any of my mobile devices enough to matter, but if I use a Web browser for Android almost exclusively, I would not want my configuration changed for no good reason in a way that is difficult to undo. I do not know many people who develop software such as, umm... Firefox?, on a smartphone.

It would be interesting to see how often someone uses a device that weighs less than 2 Kg to develop apps/programs such as Angry Birds, Libre Office, Firefox, Call of Duty, or Zoom on the trendiest Galaxy smartphone or whatever the current iPhone is.

The reason people bother with settings, bookmarks, and add-ons is that they prefer their own way of doing things and do not need some clown at a browser company making it far more difficult for them to have the browser do things their way.

Somehow, these completely unnecessary release-driven profiles in Firefox remind me of the even more bizarre changes and exciting new bugs that Microsoft introduces with every new release or update to Windows, and the many assorted patches that are (obviously) needed to correct some of the new problems introduces whenever the ill-conceived Windows registry is tampered with or Cortana detects negative thoughts about Microsoft.

"Arbitrary and capricious" is a legal term that describes the existence of release-driven profiles in Firefox. Most tech-savvy people would just expect their old settings, bookmarks, and add-ons to persist as much as possible after any update to Firefox is released by Mozilla.

They might well expect there to be a quick way to simply undo the update entirely while keeping their settings as they were before the update -- this would involve a menu item not accessible by simple accident and protected by the usual "Are you sure ... ?" warning before the user could proceed with the undo.

Oh well, Waterfox G3 just had the same sort of upgrade disorder, but I gather it is considered something to be fixed, not a feature. It is an understandable mistake, given that Waterfox must correct for all the new flaws introduced in Firefox, yet keep the good stuff, while remaining fairly current as far as browser tech goes.

Be safe, Mark

more options

Hey Mark, it's not normal to lose data during a Firefox update. Start a new question for your situation and we'll try to figure out what's going on with your system. https://support.mozilla.org/questions/new

more options

(Further update)

I have been away for 2 weeks. Thus: no input from me.

I'm back and am going to see what happens.

more options

Ok, things seen:

Though when I ask FireFox what version it is, it is only saying 83.0 and not 83.0.2.  :(

So it was (note: past tense) working fine.

A day ago a whole lot of updates installed: Security stuff. Ok. No problems.

Now Firefox is still working, but not as good.

Recap: Ubuntu 20.10 NUC I5 processor 16 G of ram.

Yes, when I load/start Firefox I have to wait for things to load.

I have a CPU load "widget" in the menu bar.

It usually looks like this: https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2020-12-18-23-42-44-3605f8.png

As Firefox is loading the load looks more like: https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2020-12-18-23-44-49-da9c00.png

But after a few minutes (as yet I haven't timed it) the load changes how it looks.

It goes from that kind of thing to this: Drats. Sorry, I thought I had taken one with the graph.

But for reasons as yet unknown: the graph suddenly goes red on top and it stays there. That isn't to say it is 100%. Just the top of the lines, there are long red lines.

Then Firefox just locks up / stops responding. Basically I have to reboot to get things back to usable.

I hope that this works with the pictures showing as I want. Alas when I "preview" I don't see the pictures.

more options

Are you testing with a large session? How many tabs do you think Firefox is trying to restore at startup?

more options

I've found if I RMB on the icon (on/in the "doc") I get an option to close all tabs.

81 is a nominal value.

Here are a couple of examples of the CPU load which show when it "crashes".

As soon as I see the appearance of any RED lines (first picture) it is pretty well given it is "All over red rover".

But if I am lucky I can RMB on the icon and quite all of them, wait for the load to get back to normal and reload/launch firefox.

Declaration: Before the update (of Ubuntu) 81 tabs was also a nominal number to restore. This was on firefox 82.x I believe. With the update of Ubuntu came Firefox 83.0.0 Yes, I had to wait for a while as they all loaded. (Not as bad as waiting for windows to load) and so it isn't a problem.

It only started after the update of Ubuntu. But for a very short time when firefox updated to 83.0.2 it seemed to be working fine. Then a couple of weeks later a whole bunch of updates came through that this is now happening.

Modified by teeny_weeny

more options

Slight update on things happening.

For the last ..... couple of hours (since my previous post) I have not been able to get firefox to load and be usable for more than about 30 seconds. Then it just "locks up". (Unresponsive)

I either have to force it to quit or reboot.

Now, it is behaving.

Something which is (maybe) of note: When I reboot, I don't have an audio device working.

To get it working, I have to do this command:

> pulseaudio -k && sudo alsa force-reload

For most of the times I have only exited firefox and reloaded it.

I have now done a full reboot and the audio device is not set, and I have **NOT** done that command.

For now firefox is stable.

I'll post now and edit if things don't go south when I do the command.

Ok, I did the command and I am still able to use firefox. (Though the response from the command has changed from what it used to be.) I say this only in that the layout of the message I see is different. Alas I don't know what the actual text is/was.

This is what I now see: me@me-desktop:~$ RSA /sbin/alsa: Warning: Processes using sound devices: 1449(timidity). Unloading ALSA sound driver modules: snd-seq-dummy snd-hrtimer snd-hda-codec-hdmi snd-hda-codec-realtek snd-hda-codec-generic snd-hda-intel snd-intel-dspcfg snd-hda-codec snd-hda-core snd-hwdep snd-pcm snd-seq-midi snd-seq-midi-event snd-rawmidi snd-seq snd-seq-device snd-timer (failed: modules still loaded: snd-hrtimer snd-hda-codec-hdmi snd-hda-codec-realtek snd-hda-codec-generic snd-hda-intel snd-intel-dspcfg snd-hda-codec snd-hda-core snd-hwdep snd-pcm snd-seq snd-seq-device snd-timer). Loading ALSA sound driver modules: snd-seq-dummy snd-hrtimer snd-hda-codec-hdmi snd-hda-codec-realtek snd-hda-codec-generic snd-hda-intel snd-intel-dspcfg snd-hda-codec snd-hda-core snd-hwdep snd-pcm snd-seq-midi snd-seq-midi-event snd-rawmidi snd-seq snd-seq-device snd-timer.

Yeah, sorry, not exactly in the scope of this, but to keep all the cards on the table. Sometimes weird things are common.

Anyway, so it isn't that. (I think.)

The system has now been working stable for a while now. (Sorry the times aren't shown that clearly and all I can say is that what ever the problem is/was: It has since gone, and all is good.)

Modified by teeny_weeny

more options

Ok, another update: (I am going to put local times here so as to help with when things are happening.)

13:17 I posted that reply a while back. Things went bad after that. A few times I went to a site - one of the many tabs in what are loaded at start up - and things went bad. I exited firefox rather than rebooting, but it got to the stage where I had to.

Observations: Above the sound device problem was cleared/fixed. It is rather annoying going to (for example) youtube if you don't have sound. As it was, it was more a forum to which I went and firefox just kept dieing. (how ever it is spelt)

So, now I have rebooted and the sound device is a dummy one.

I'll go to that forum and see if things work. (I'll post now as if it all goes south, I won't be able to update this in real time)

13:24 Went to site and all good. No crash.

I'll fix the audio device and go back to the site, and report back with what happens. Though it may not crash now, as it may be something to do with the initial loading of the page. But who knows? Back soon I hope.

13:30 Ok: "Fixed" audio device. Went back to that tab. Working. Reloaded the page. Working. Opened a new tab on same page: working.

Unsure if the audio device is part of the problem. I shall reboot now (yuck) but fix audio device and try to visit that forum again.

(Ok, weird. the post wasn't posted)

13:33 Rebooted. Audio device wrong. Fixed. Loaded firefox. Ok so far. 13:37 and it locks up (see picture) 13:43 Rebooted: no audio fix. Back to firefox.

Shall try the forum site now. (Condition: audio device not set correctly.)

13:49 No luck. Locked up. Rebooted. See second picture.

So as it is now: Rebooted. No audio device. NOT visited forum.

All good.

Modified by teeny_weeny

more options

Dec 22 16:34 (local)

I have just got the NUC running with 32 Gig of memory now.

I'll see if this makes any difference to what is happening.

Update: 19:21 (local)

The machine has been running smoothly now though I haven't pushed it too hard, I have given it a bit of a work out.

No crashes/lock ups as yet.

(Though I think Mr Murphy may step in shortly after this post and mess all that up.) <wink>

Modified by teeny_weeny

more options

الحل المُختار

24 Dec 12:18 (local)

I have had Firefox running now for a while (on this session) and though I may not have flogged it that hard, I have been on a video conference for 2 hours and not a glitch.

It may be the extra 16 gig of memory has fixed (resolved?) the problem I was having.

  1. 1
  2. 2