Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Many page elements won't load

more options

I refreshed my firefox a few minutes ago and the only way I can describe it now is broken. Many page elements won't load such as images on some sites, and in the example I give here, the dark theme slider on YT doesn't show up at all. when I open the sidebar, the rest of the page becomes completely white. And the page is supposed to already be in dark theme. I am using the windows version. Can anybody help with this?

Attached screenshots

Chosen solution

Make sure you haven't enabled a High Contrast theme in the OS settings.

Make sure you allow pages to choose their own colors.

  • Options/Preferences -> General: Fonts & Colors -> Colors: "Override the colors specified by the page with my selections above"

Try "Never" if the default "Only with High Contrast themes" isn't working.

Read this answer in context 👍 1

All Replies (7)

more options

Same here. No matter what website I open the parts of site doesnt load. Have to refresh it once again to fix the issue.

Helpful?

more options

So refreshing firefox again after it broke fixed the issue?

Helpful?

more options

yairmaor said

So refreshing firefox again after it broke fixed the issue?

Yes, if you refresh the website it will fix it but issue is still there. I open a lot of tabs in background always and this crap is annoying now.

Modified by smokeyoriginalhd1125

Helpful?

more options

Chosen Solution

Make sure you haven't enabled a High Contrast theme in the OS settings.

Make sure you allow pages to choose their own colors.

  • Options/Preferences -> General: Fonts & Colors -> Colors: "Override the colors specified by the page with my selections above"

Try "Never" if the default "Only with High Contrast themes" isn't working.

Helpful?

more options

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content. You can click shield icon for more detail and possibly disable the protection. You can check the Web Console for messages about blocked content.


You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" for websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

Helpful?

more options

thanks a lot setting the color override to never fixed it

Helpful?

more options

Dark Reader addon caused this issue in my case.

Helpful?

اطرح سؤالا

عليك الولوج إلى حسابك للردّ على المشاركات. من فضلك اطرح سؤالًا جديدًا لو لم يكن لديك حساب بعد.