Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox Extensions and Themes

  • 2 replies
  • 1 has this problem
  • 7 views
  • آخر ردّ كتبه elicea0412

more options

Hello everyone.

I am having an issue with Firefox Desktop on my Linux machine(MX Linux). Before I was able to install themes and extensions from the marketplace just fine. However recently when I try to install a theme or extension through the marketplace, I get the green button that says "Only with Firefox -- Get Firefox Now" instead of the blue button that says "Add to Firefox".

I have tried purging all files and re-installing the application. I even went as far as deleting anything Firefox that was in my root files. I was able to change the theme and add a suggested extension through the Add-On settings but that was all.

To me it seems like the marketplace is not recognizing the browser as Firefox. Any help is much obliged.

Chosen solution

The Mozilla Add-ons site uses your browser's user agent string to detect your Firefox version. Any alterations to the string may cause mis-detection.

This forum recorded a completely blank user agent string for your post, which is weird. Do you use any settings or external middlemen (such as proxy servers) to modify your user agent string?

For the internal setting, see: How to reset the default user agent on Firefox

I have a test page here that shows the user agent string detected by the page: https://www.jeffersonscher.com/res/jstest.php

Read this answer in context 👍 1

All Replies (2)

more options

Chosen Solution

The Mozilla Add-ons site uses your browser's user agent string to detect your Firefox version. Any alterations to the string may cause mis-detection.

This forum recorded a completely blank user agent string for your post, which is weird. Do you use any settings or external middlemen (such as proxy servers) to modify your user agent string?

For the internal setting, see: How to reset the default user agent on Firefox

I have a test page here that shows the user agent string detected by the page: https://www.jeffersonscher.com/res/jstest.php

Helpful?

more options

I thought it migh've had to do something with the user-agent. That was it exactly. I was able to reset it and now everything works great! thanks for the help!

Modified by elicea0412

Helpful?

اطرح سؤالا

عليك الولوج إلى حسابك للردّ على المشاركات. من فضلك اطرح سؤالًا جديدًا لو لم يكن لديك حساب بعد.