Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why is my broswer in Telugu?

  • 2 replies
  • 1 has this problem
  • 2 views
  • آخر ردّ كتبه cor-el

more options

My browser despite being set to English is displaying pages in Tegulu. This seems to be an issue relating to how FF and Google are interfacing. For example the NYT is only in English, but any Google search results are in Tegulu. Any suggestions?

All Replies (2)

more options

For your kind information, This is not related to Firefox but your google language setting. If you have logged into Google, please go to this link Google language setting

and make sure your search language setting is set to English if you wish english.

If not logged in, go to Google.com and in home page, please make sure proper language is selected.

Helpful?

more options

You can check the preferred languages for web pages.


You can clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" for websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Helpful?

اطرح سؤالا

عليك الولوج إلى حسابك للردّ على المشاركات. من فضلك اطرح سؤالًا جديدًا لو لم يكن لديك حساب بعد.