Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Save as only saves to documents

  • 13 replies
  • 1 has this problem
  • 14 views
  • آخر ردّ كتبه Bud05437

more options

When I use "save image as", format shows only documents and all files. I can't save as jpg...Firefox 79.0 I used to be able to right click on "Save image as" and JPG was an option. JPG is no longer shown, only "Documents or All files". How can I save images now?

Chosen solution

Yes, this is the new normal with image servers, that they add webP compression on the fly to JPEG and PNG images. Currently, the best workaround is my extension:

https://addons.mozilla.org/firefox/addon/dont-accept-webp/

If you don't want to use an extension, you can look at converter programs to use after download.

Read this answer in context 👍 0

All Replies (13)

more options

Did you try to use "All files" and add the correct file extension (.jpg) yourself ?

Helpful?

more options

Hi Bud05437, could you try this:

right-click (or Ctrl+click) the image, then Command+click on View Image to launch the image into a new tab

When you hover your mouse over the image's tab, Firefox should indicate its true format. If it's WebP, that would explain the weird document type in the Save As dialog. On many systems, WebP has an associate described as something like Chrome HTML document.

WebP is a compression format invented by Google that many sites are using to save on bandwidth when serving any kind of image. The problem for Firefox users is:

(A) The sites don't change the original filename in spite of the format change, and (B) Firefox doesn't have a converter built into the Save Image As function

If your applications cannot work with WebP images, then a couple of workarounds are:

(1) Use an add-on to stop Firefox telling sites it is happy to receive WebP-format image. I posted one here:

https://addons.mozilla.org/firefox/addon/dont-accept-webp/

(2) Use an add-on that can save webP images in another format of your choice.

You might not need this very often if you use the first approach.

Helpful?

more options

Nope, no joy. I wish I could go back to an old version of Firefox when I could right click on a picture and it would save image as JPG.

Helpful?

more options

When I choose all files, it shows up on my desktop as a JPG. But when I try to open it, I get this: It may be damaged or use a file format that Preview doesn’t recognize.

Helpful?

more options

Bud05437 said

When I choose all files, it shows up on my desktop as a JPG. But when I try to open it, I get this: It may be damaged or use a file format that Preview doesn’t recognize.

I think that confirms it's not a JPEG format image. Did you try the new tab test?

Helpful?

more options

When I right click on the image and I get the drop down save as menu, the view menu disappears.

Helpful?

more options

Bud05437 said

When I right click on the image and I get the drop down save as menu, the view menu disappears.

Usually View Image is higher on the menu than Save Image As. I'm attaching a screenshot of how I see it on Windows (left: image only, right: linked image).

Helpful?

more options

If you give the image you saved as .jpg instead give a .webp file extension, does that allow you to open image in a Firefox tab ?

Helpful?

more options

When I view the image in a different tab and try to save as, I still only get a choice format of document or all files.

Helpful?

more options

Okay, but I'm suggesting this as a method of diagnosis of the problem.

When you have the image in its own tab and you move your mouse pointer up and hover over the tab, what format does Firefox say it is in the tooltip? For example, these are images from past threads about how JPG wasn't really a JPG. You can tell it's WebP from the tab tooltip.

Note: saving from a stand-alone tab is not a solution. For now, if you don't want sites to apply WebP compression when they serve you .JPG files, you can use my add-on to discourage them.

Helpful?

more options

Type. image/webp Got no clue why this changed with the last update. I know my Chrome browser works the way the older version of Firefox did. Save as comes up with JPG.

Helpful?

more options

Chosen Solution

Yes, this is the new normal with image servers, that they add webP compression on the fly to JPEG and PNG images. Currently, the best workaround is my extension:

https://addons.mozilla.org/firefox/addon/dont-accept-webp/

If you don't want to use an extension, you can look at converter programs to use after download.

Helpful?

more options

You did great!!! I'm back in business. Thanks, Bud

Helpful?

اطرح سؤالا

عليك الولوج إلى حسابك للردّ على المشاركات. من فضلك اطرح سؤالًا جديدًا لو لم يكن لديك حساب بعد.