Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

For the love of god how do you disable first-run (welcome) page????

  • 8 replies
  • 1 has this problem
  • 45 views
  • آخر ردّ كتبه Mike Kaply

more options

Hi I am looking for a way to disable the Firefox Welcome Page on first run, via script, or registry or config file, I have it coming up on over 1000 Windows 10 pc's running Firefox 64 bit 78.02

I have tried many things and nothing I have done seems to suppress the welcome page.

I tried setting all to blank and none have worked

startup.homepage_welcome_url

startup.homepage_welcome_url.additional

startup.homepage_override_url

Also I have tried in the Policies.json file the following. The welcome page still comes up.

{

   "policies": {
       "OverrideFirstRunPage": "",
       "OverridePostUpdatePage": ""
   }

}

All Replies (8)

more options

Please attach an image as to what you want to remove. I am not able to understand your query. Nevertheless, according to what I understood, you can change the appearance of the first page when firefox loads by going to Preferences > Home and changing the selecting the options as you like it. Also, you can make firefox remember the session by going to Preferences > General, so it always opens up in the same state as you closed it. Hope it helps.

Helpful?

more options

This is what I am trying to suppress....

Helpful?

more options

Helpful?

more options

I think this is what you need:

Type about:config<enter> in the address bar. If a warning screen comes up, press the I Accept the Risk button. At the top of the screen is a search bar.

Change trailhead.firstrun.didSeeAboutWelcome = True

Helpful?

more options

nope the welcome still shows up with

trailhead.firstrun.didSeeAboutWelcome = True

Helpful?

more options

Hi Clivebuckwheat

I'll ask a Firefox engineer to take a look.

Cheers! ...Roland

Modified by Roland Tanglao

Helpful?

more options

In the past we used to do this via browser.startup.homepage_override.mstone = ignore.

You can try if this still works in an autoconfig.cfg file.

//
lockPref("browser.startup.homepage_override.mstone", "ignore");

Helpful?

more options

I'm sorry you're seeing this. This was a bug that is fixed in the Firefox released today:

> In previous versions of Firefox, disabling sync or overriding the first run page removed the onboarding messages from the new tab page. This was fixed in bug 1651093.

If you need to do it before today's release. You can do the folllowing:

lockPref("trailhead.firstrun.branches", "nofirstrun-empty"); lockPref("browser.aboutwelcome.enabled", false);

Again, my apologies for missing this.

Helpful?

اطرح سؤالا

عليك الولوج إلى حسابك للردّ على المشاركات. من فضلك اطرح سؤالًا جديدًا لو لم يكن لديك حساب بعد.