Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Bookmark Problem

  • 4 replies
  • 1 has this problem
  • 12 views
  • آخر ردّ كتبه dwhite300

more options

Windows and/or Firefox updated recently and something odd is happening. If I open Firefox from my desktop I can access my bookmarks, no problem. If I read my emails in Windows Live Mail and click on a link from an email to a website, the web page opens but I cannot access my bookmarks from this window. They just aren't there. I have to go and open Firefox from the desktop or from the icon in the menu bar.

Anyone have an idea what happened and how to fix?

Chosen solution

Aha, different profile. Could you check whether your normal profile is the "default" profile? Firefox uses the default profile for external links. Here's how you check:

Profile Manager Page

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

This page should list at least one profile and could list many. (Each profile has two folders and one or more buttons. Do not use any Remove buttons!)

The profile that Firefox is currently using will have this:

This is the profile in use and it cannot be deleted.

That should match the name you mentioned (those numbers are a date/time stamp for when that profile was created by using the Refresh feature). If that profile has a Set as default profile button, go ahead and click that so external links use that profile.

If that profile doesn't have that button, usually that means it already is the default profile and there must be some other, less obvious explanation for the way Firefox opens external links in a different profile...

Read this answer in context 👍 0

All Replies (4)

more options

That is strange. Are you normally using:

  • Bookmarks Toolbar
  • Bookmarks Menu button on the top menu bar
  • optional Bookmarks Menu toolbar button
  • Bookmarks Sidebar (Ctrl+b, if the page doesn't repurpose it)

If the windows are really different, could you compare something for me: in each window, the more normal one and the email one, open the Troubleshooting Information page. There are a variety of ways to do it ("whatever works"):

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter/Return

In the first table on the page, on the Profile folder row, Firefox will list the profile that window is running in. Is it the same profile, or are they using different profiles?

Helpful?

more options

I normally use the bookmarks menu button on the top menu bar.

The profiles are different. The one that shows the bookmarks correctly has a .default along with a string of characters in the file name. The path appears to be the same.

Dan

Helpful?

more options

Chosen Solution

Aha, different profile. Could you check whether your normal profile is the "default" profile? Firefox uses the default profile for external links. Here's how you check:

Profile Manager Page

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

This page should list at least one profile and could list many. (Each profile has two folders and one or more buttons. Do not use any Remove buttons!)

The profile that Firefox is currently using will have this:

This is the profile in use and it cannot be deleted.

That should match the name you mentioned (those numbers are a date/time stamp for when that profile was created by using the Refresh feature). If that profile has a Set as default profile button, go ahead and click that so external links use that profile.

If that profile doesn't have that button, usually that means it already is the default profile and there must be some other, less obvious explanation for the way Firefox opens external links in a different profile...

Helpful?

more options

You, Sir, are a genius!!! You nailed it!. There was a button to save as default and I clicked it. One less petty annoyance in life solved.

Thanks again.

Dan

Helpful?

اطرح سؤالا

عليك الولوج إلى حسابك للردّ على المشاركات. من فضلك اطرح سؤالًا جديدًا لو لم يكن لديك حساب بعد.