Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Spellchecker not working (it's switched on and I have a dictionary)

  • 9 replies
  • 1 has this problem
  • 24 views
  • آخر ردّ كتبه tatew1

more options

I can't get spellcheck to work. I'm using Firefox on a Mac. This is true even when using a box with multiple lines.

I have ticked the box in preferences that says Check your spelling as you type. I have a language chosen - English (United Kingdom). I tried installing a different dictionary in Add-ons, but it made no difference.

I've gone into about:config and adjusted the settings in layout.spellcheckDefault and checked services.sync.prefs.sync.layout.spellcheckDefault, which made no difference.

I've read posts that say to right click and look at the dictionaries, but this doesn't work for me (could be because I'm using a Mac). Same with pressing Control.

Any thoughts?

Attached screenshots

Chosen solution

A language pack has nothing to do with spell checking like I wrote. Installed dictionaries would appear under Dictionaries on the about:addons page.

Don't you see the Languages sub menu as well if you right-click in the "Post a Reply" form on this web page ?

Note that the en-GB Firefox version doesn't come with a dictionary for licensing reason and you need to install the en-GB dictionary from the Add-ons website.

Read this answer in context 👍 0

All Replies (9)

more options

Type about:config<enter> in the address bar. If a warning screen comes up, press the I Accept the Risk button. At the top of the screen is a search bar.

Type: layout.spellcheckDefault Its values are; 0 Spell Checker Off 1 Check Only Multi-Line Input Boxes. 2 Check Multi And Single Line Input Boxes.

Also, check the spellchecker.dictionary entry.

https://support.mozilla.org/en-US/kb/how-do-i-use-firefox-spell-checker

Helpful?

more options

I'd already tried everything except checking the spellchecker.dictionary entry, but that hasn't fixed it either.

Helpful?

more options

Separate Security Issue: Update your Flash Player or remove it using these links;
Uninstall Flash Player | Windows {web link}
Uninstall Flash Player | Mac {web link}

Note: Windows users should download the
ActiveX for Internet Explorer. and the plugin for
Plugin-based browsers (like Firefox).

Note: Windows 8 and Windows 10 have built-in
flash players and Adobe will cause a conflict. Install
the plugin only. Not the ActiveX.

Flash Player Version: 32.0.0.387

https://get.adobe.com/flashplayer/
Direct link scans current system and browser
Note: Other software is offered in the download. <Windows Only>

https://get.adobe.com/flashplayer/otherversions/
Step 1: Select Operating System
Step 2: Select A Version (Firefox, Win IE . . . .)
Note: Other software is offered in the download. <Windows Only>
+++++++++++++++++++++++++++++++++++
See if there are updates for your graphics drivers
https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

Modified by James

Helpful?

more options

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Helpful?

more options

Thanks for the suggestion, but the problem is still there.

Helpful?

more options

What your screenshot shows is about the language for the user interface (language packs) and not about dictionaries for spell checking.


Do you have a dictionary installed and selected?

You can see which dictionary is selected if you right-click in a text area and open the Languages sub menu.
At least one dictionary should be installed and have a check mark to indicate that it is selected.

  • open the "Add Dictionaries" link to install a dictionary if you do not have one.

The spelling checker is enabled if [X] "Check Spelling" in the right-click context menu has a checkmark.

You can enable or disable spell checking globally:

  • Options/Preferences -> General: Language and Appearance: "Check your spelling as you type"

You can look here for dictionaries:

Note that for spell check you need a dictionary.
A language pack provides string translations for the user interface.
*https://support.mozilla.org/en-US/kb/use-firefox-interface-other-languages-language-pack

Helpful?

more options

Hi, I've already tried installing an add-on dictionary, which didn't help. I'm using a Macbook, so there isn't a right click and the equivalent (using control+click) doesn't bring up an option to check spelling. If I click, my only options are undo, cut, copy, paste and inspect element (screenshot attached).

Although I've installed the English (GB) Language Pack and it appears under add-ons, it doesn't offer it as an option under Languages in Preferences. It doesn't come up in the drop-down list or when I click on alternatives. See the attached screenshot.

Helpful?

more options

Chosen Solution

A language pack has nothing to do with spell checking like I wrote. Installed dictionaries would appear under Dictionaries on the about:addons page.

Don't you see the Languages sub menu as well if you right-click in the "Post a Reply" form on this web page ?

Note that the en-GB Firefox version doesn't come with a dictionary for licensing reason and you need to install the en-GB dictionary from the Add-ons website.

Helpful?

more options

Thanks so much for your help. Now I've installed that dictionary I can see languages when I click in the text box. What a relief.

Helpful?

اطرح سؤالا

عليك الولوج إلى حسابك للردّ على المشاركات. من فضلك اطرح سؤالًا جديدًا لو لم يكن لديك حساب بعد.